Code

README.templates.d: Added README file for the use of /e/pnp4nagios/templates.d.
[pkg-pnp4nagios.git] / debian / rules
index 9f9611aa186511ef772dc2ff2b68e6af34dd8967..b9e40d08de68c35d6e5c7c361280869cb747a35a 100755 (executable)
@@ -39,7 +39,11 @@ config.status: configure
                                --with-httpd-conf=/etc/apache2/conf.d \
                                CFLAGS="$(CFLAGS)"
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+
+build-indep: build-stamp
 
 build-stamp: $(QUILT_STAMPFN) config.status
        dh_testdir
@@ -69,8 +73,6 @@ clean: unpatch
 
        [ ! -f Makefile ] || $(MAKE) distclean
 
-       rm -f scripts/rc.pnp_gearman_worker
-
        dh_clean
        debconf-updatepo
 
@@ -153,6 +155,9 @@ install: build
        rmdir debian/tmp/usr/share/pnp4nagios/html/application/hooks/
        #rmdir debian/tmp/usr/share/pnp4nagios/html/application/libraries/
 
+       mkdir debian/tmp/etc/pnp4nagios/templates.d
+       cp debian/README.templates.d debian/tmp/etc/pnp4nagios/templates.d/README
+
        dh_install --sourcedir=debian/tmp --fail-missing
 
 # Build architecture-independent files here.