Code

patches: Added CXXFLAGS.dpatch to remove -O3 from CXXFLAGS.
[pkg-pfstmo.git] / debian / rules
index c8625e78510285c23e2e0539f2c37316d54cb398..382daf723d494e5cd0fde8e902adfa82d53d42ff 100755 (executable)
@@ -22,9 +22,15 @@ else
        CXXFLAGS += -O2
 endif
 
-config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
+       # do not rebuild the build system
+       touch aclocal.m4 acinclude.m4 configure.ac configure config.h.in \
+               config.status Makefile.am Makefile.in Makefile
+       
        for file in config.guess config.sub; do \
                if [ ! -e $$file.upstream ]; then \
                        mv $$file $$file.upstream; \
@@ -59,6 +65,8 @@ clean:
                fi \
        done
        
+       $(MAKE) -f debian/rules unpatch
+       
        dh_clean
 
 install: build