Code

Disable the sigrok plugin for now.
[pkg-collectd.git] / debian / rules
index b3325ec7870a430c57e3f380e30fb5dca1fbbdbf..e4df1c87989ea0e520ae9c98878692707eb8ad8c 100755 (executable)
@@ -91,6 +91,10 @@ confflags += --disable-grpc
 # libqpos is required for the intel_rdt plugin.
 confflags += --disable-intel_rdt
 
+# libsigrok4 incompatible with the plugin.
+# Cf. https://github.com/collectd/collectd/issues/1574
+confflags += --disable-sigrok
+
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
@@ -111,10 +115,6 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-numa \
                --disable-sensors \
                --disable-vserver
-       # libsigrok >= 0.2.0 is required for the sigrok plugin,
-       # only available on Linux.
-       confflags += \
-               --disable-sigrok
 endif
 
 # This plugin is FreeBSD-specific.