Code

Disable the gmond plugin for now.
[pkg-collectd.git] / debian / rules
index 316eba88fd0e300da6fb500c7b8d0f1324f4ecd6..db3b61f05762cd1dadf902e5c06c472bc4456ac9 100755 (executable)
@@ -19,12 +19,6 @@ CPPFLAGS += -I$(CURDIR)/debian/include
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-error=deprecated-declarations
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
-
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
@@ -73,6 +67,10 @@ confflags += --disable-tape
 # libaquaero5 is required for the aquaero plugin
 confflags += --disable-aquaero
 
+# Ganglia is not available in testing atm and hasn't been touched in a long
+# time, http://bugs.debian.org/812462
+confflags += --disable-gmond
+
 # libmic is required for the mic plugin
 confflags += --disable-mic
 
@@ -286,8 +284,7 @@ binary-arch: build install-arch
        dh_systemd_start -pcollectd-core
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
-       # dh_strip_nondeterminism is broken atm
-       #dh_strip_nondeterminism -pcollectd-core
+       dh_strip_nondeterminism -pcollectd-core
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a