Code

rules: Added ‘powerpcspe’ to JAVA_ARCHDIR_MAP.
[pkg-collectd.git] / debian / rules
index 5a50f3a2df14b493ae043623af7c054026ff5667..ce981a4b997b84c255f8c0c4578d39e475876732 100755 (executable)
@@ -1,7 +1,7 @@
 #! /usr/bin/make -f
 # debian/rules for collectd
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -26,12 +26,27 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
+# The archdir map has been copied from openjdk-6's debian/rules.
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc powerpcspe=ppc sh4=sh
+JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
+                       $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+ifeq (,$(JAVA_ARCHDIR))
+       JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
+endif
+JAVA_HOME = /usr/lib/jvm/java-6-openjdk
+JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
+
+JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
+JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
+JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
+
 include /usr/share/dpatch/dpatch.make
 
 confflags = --host=$(DEB_HOST_GNU_TYPE) \
@@ -39,27 +54,106 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --mandir=\$${prefix}/share/man \
                        --localstatedir=/var --sysconfdir=/etc \
                        --with-perl-bindings="INSTALLDIRS=vendor" \
-                       --disable-onewire \
-                       --disable-xmms \
-                       --without-libstatgrab
+                       --without-libstatgrab \
+                       --without-included-ltdl \
+                       --disable-static \
+                       --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libmodbus is required for the modbus plugin.
+confflags += --disable-modbus
+
+# libnetapp is required for the netapp plugin.
+confflags += --disable-netapp
+
+# libowcapi is required for the onewire plugin.
+confflags += --disable-onewire
+
+# libclntsh is required for the oracle plugin.
+confflags += --disable-oracle
+
+# librouteros is required for the routeros plugin.
+confflags += --disable-routeros
+
+# xmms1 is required for the xmms plugin.
+confflags += --disable-xmms
+
+# libkstat is required for the xfs_arc plugin.
+confflags += --disable-zfs-arc
+
 # The static library netstat cannot be linked into shared objects on some
-# architectures (see bugs #358637 and #419684 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
+# architectures (see bugs #358637, #419684 and #524593 for more details).
+ifneq (,$(filter alpha amd64 hppa ia64 ppc64 mips mipsel, $(DEB_BUILD_ARCH)))
        confflags += --disable-netlink
 endif
 
-# libvirt is only available on amd64, i386 and powerpc.
-ifeq (,$(findstring $(DEB_BUILD_ARCH),amd64 i386 powerpc))
-       confflags += --disable-libvirt
+# These plugins are Linux-specific.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-madwifi \
+               --disable-netlink \
+               --disable-sensors \
+               --disable-vserver
+endif
+
+# These plugins have not been ported to FreeBSD yet.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-battery \
+               --disable-conntrack \
+               --disable-contextswitch \
+               --disable-cpufreq \
+               --disable-disk \
+               --disable-entropy \
+               --disable-fscache \
+               --disable-irq \
+               --disable-nfs \
+               --disable-protocols \
+               --disable-serial \
+               --disable-thermal \
+               --disable-vmem \
+               --disable-wireless
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-gmond \
+               --disable-libvirt \
+               --disable-tokyotyrant \
+               --disable-java
+endif
+
+# The hppa buildds currently do not keep up with Java related stuff, thus
+# prevending testing transitions.
+ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
+       confflags += --disable-java
 endif
 
 config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
-       CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" ./configure $(confflags)
+       
+       ( cd debian/patches/; for patch in *; do \
+               if test "$$patch" != "00list"; then \
+                       grep "$$patch" 00list > /dev/null \
+                               || ( echo "$$patch not enabled\!"; exit 1 ); \
+               fi; done )
+       
+       # This is a work-around for #474087 (broken openipmi .pc files).
+       mkdir debian/pkgconfig
+       sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
+               /usr/lib/pkgconfig/OpenIPMIpthread.pc \
+               > debian/pkgconfig/OpenIPMIpthread.pc
+       
+       PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
+       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+               JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
+               || ( status=$$?; cat config.log; exit $$status )
 
 build: build-stamp
 
@@ -81,6 +175,8 @@ clean: unpatch
        rm -f debian/README.Debian.plugins
        rm -f src/*.1 src/*.5
        
+       rm -rf debian/pkgconfig
+       
        dh_clean
        debconf-updatepo
 
@@ -100,15 +196,16 @@ install-arch: build
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        rm -f debian/tmp/usr/lib/collectd/*.la
+       rm -f debian/tmp/usr/lib/libcollectdclient.la
        rm -f debian/tmp/etc/collectd.conf
        
        dh_install -a --sourcedir=$(CURDIR)/debian/tmp --fail-missing
        
        perl ./debian/bin/gen_plugin_deps.pl
        
-       mkdir -p debian/collectd/usr/share/lintian/overrides/
-       cp debian/collectd.overrides \
-               debian/collectd/usr/share/lintian/overrides/collectd
+       mkdir -p debian/collectd-core/usr/share/lintian/overrides/
+       cp debian/collectd-core.overrides \
+               debian/collectd-core/usr/share/lintian/overrides/collectd-core
 
 binary-indep: install-indep
        dh_testdir
@@ -136,23 +233,33 @@ binary-arch: build install-arch
                contrib/exec-nagios.conf contrib/exec-nagios.px \
                contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
-               contrib/collectd-network.py contrib/collectd-unixsock.py \
-               contrib/snmp-probe-host.px
-       # the 4.6.2 upstream tarball had been built inside a dirty working dir
-       rm debian/collectd/usr/share/doc/collectd/examples/collection3/bin/foo
+               contrib/collectd_network.py contrib/collectd_unixsock.py \
+               contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               debian/collectd.conf debian/filters.conf debian/thresholds.conf
+       # some upstream tarballs have been built inside a dirty working dir
+       ( cd debian/collectd-core/ \
+               && cd usr/share/doc/collectd-core/examples/collection3/ \
+               && rm -f bin/foo bin/test_config.px etc/collection4.conf \
+               && rm -f lib/Collectd/Graph.pm lib/Collectd/Graph/Data.pm \
+               && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
+               && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
-       dh_installinit -a -- defaults 95
+       dh_installinit -pcollectd-core --name=collectd -- defaults 95
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a
        dh_installdeb -a
+       dh_shlibdeps -a -Ncollectd-core -Ncollectd
        dpkg-shlibdeps -Tdebian/collectd.substvars \
-               -dDepends debian/collectd/usr/sbin/* \
-                       debian/collectd/usr/lib/collectd/rrdtool.so \
-               -dRecommends debian/collectd/usr/lib/collectd/*.so
-       dh_shlibdeps -a -Ncollectd
+               -dDepends debian/collectd-core/usr/lib/collectd/rrdtool.so
+       dpkg-shlibdeps -Tdebian/collectd-core.substvars \
+               -dDepends debian/collectd-core/usr/sbin/* \
+               -dSuggests debian/collectd-core/usr/lib/collectd/*.so
+       grep shlibs:Suggests debian/collectd-core.substvars \
+               | sed -e 's/shlibs:Suggests/shlibs:Recommends/' \
+               >> debian/collectd.substvars
        dh_gencontrol -a
        dh_md5sums -a
        dh_builddeb -a