Code

rules: Added ‘powerpcspe’ to JAVA_ARCHDIR_MAP.
[pkg-collectd.git] / debian / rules
index 1f902deaef10cf46e027010e41fe558a65a13264..ce981a4b997b84c255f8c0c4578d39e475876732 100755 (executable)
@@ -26,22 +26,24 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = alpha=alpha arm=arm armel=arm amd64=amd64 hppa=parisc \
-                       i386=i386 lpia=i386 m68k=m68k mips=mips mipsel=mipsel \
-                       powerpc=ppc sparc=sparc s390=s390 ia64=ia64
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc powerpcspe=ppc sh4=sh
 JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
                        $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+ifeq (,$(JAVA_ARCHDIR))
+       JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
+endif
 JAVA_HOME = /usr/lib/jvm/java-6-openjdk
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
 JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
@@ -53,22 +55,27 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --localstatedir=/var --sysconfdir=/etc \
                        --with-perl-bindings="INSTALLDIRS=vendor" \
                        --without-libstatgrab \
+                       --without-included-ltdl \
+                       --disable-static \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libmodbus is required for the modbus plugin.
+confflags += --disable-modbus
+
+# libnetapp is required for the netapp plugin.
+confflags += --disable-netapp
+
 # libowcapi is required for the onewire plugin.
 confflags += --disable-onewire
 
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
-# rrdclient support in librrd is required for the rrdcached plugin.
-confflags += --disable-rrdcached
-
-# libtokyotyrant is required for the tokyotyrant plugin.
-confflags += --disable-tokyotyrant
+# librouteros is required for the routeros plugin.
+confflags += --disable-routeros
 
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
@@ -78,19 +85,64 @@ confflags += --disable-zfs-arc
 
 # The static library netstat cannot be linked into shared objects on some
 # architectures (see bugs #358637, #419684 and #524593 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
+ifneq (,$(filter alpha amd64 hppa ia64 ppc64 mips mipsel, $(DEB_BUILD_ARCH)))
        confflags += --disable-netlink
 endif
 
+# These plugins are Linux-specific.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-madwifi \
+               --disable-netlink \
+               --disable-sensors \
+               --disable-vserver
+endif
+
+# These plugins have not been ported to FreeBSD yet.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-battery \
+               --disable-conntrack \
+               --disable-contextswitch \
+               --disable-cpufreq \
+               --disable-disk \
+               --disable-entropy \
+               --disable-fscache \
+               --disable-irq \
+               --disable-nfs \
+               --disable-protocols \
+               --disable-serial \
+               --disable-thermal \
+               --disable-vmem \
+               --disable-wireless
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-gmond \
+               --disable-libvirt \
+               --disable-tokyotyrant \
+               --disable-java
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
+ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
 config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
+       ( cd debian/patches/; for patch in *; do \
+               if test "$$patch" != "00list"; then \
+                       grep "$$patch" 00list > /dev/null \
+                               || ( echo "$$patch not enabled\!"; exit 1 ); \
+               fi; done )
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -99,8 +151,9 @@ config.status: configure $(DPATCH_STAMPFN)
        
        PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
        ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
-               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
-               JAVA_LDFLAGS="$(JAVA_LDFLAGS)"
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+               JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
+               || ( status=$$?; cat config.log; exit $$status )
 
 build: build-stamp
 
@@ -180,8 +233,9 @@ binary-arch: build install-arch
                contrib/exec-nagios.conf contrib/exec-nagios.px \
                contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
-               contrib/collectd-network.py contrib/collectd-unixsock.py \
-               contrib/snmp-probe-host.px contrib/GenericJMX.conf
+               contrib/collectd_network.py contrib/collectd_unixsock.py \
+               contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               debian/collectd.conf debian/filters.conf debian/thresholds.conf
        # some upstream tarballs have been built inside a dirty working dir
        ( cd debian/collectd-core/ \
                && cd usr/share/doc/collectd-core/examples/collection3/ \
@@ -198,8 +252,8 @@ binary-arch: build install-arch
        dh_makeshlibs -a
        dh_installdeb -a
        dh_shlibdeps -a -Ncollectd-core -Ncollectd
-       dh_shlibdeps -pcollectd \
-               -- -edebian/collectd-core/usr/lib/collectd/rrdtool.so
+       dpkg-shlibdeps -Tdebian/collectd.substvars \
+               -dDepends debian/collectd-core/usr/lib/collectd/rrdtool.so
        dpkg-shlibdeps -Tdebian/collectd-core.substvars \
                -dDepends debian/collectd-core/usr/sbin/* \
                -dSuggests debian/collectd-core/usr/lib/collectd/*.so