Code

rules: Fix the arch selection for enabling the gRPC plugin.
[pkg-collectd.git] / debian / rules
index cac99e0d8b81fd6da2ce193d887201590ac250d3..80f1bc9829f66f57eec4d1d32aa67e1ddc2ad561 100755 (executable)
@@ -67,6 +67,9 @@ confflags += --disable-tape
 # libaquaero5 is required for the aquaero plugin
 confflags += --disable-aquaero
 
+# libjevents is required for the intel_pmu plugin
+confflags += --disable-intel_pmu
+
 # libmic is required for the mic plugin
 confflags += --disable-mic
 
@@ -82,20 +85,10 @@ confflags += --disable-routeros
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# protobuf-compiler >= 3.0.0 and libgrpc++ are required for the grpc plugin.
-confflags += --disable-grpc
-
-# libqpos is required for the intel_rdt plugin.
-confflags += --disable-intel_rdt
-
 # libsigrok4 incompatible with the plugin.
 # Cf. https://github.com/collectd/collectd/issues/1574
 confflags += --disable-sigrok
 
-# libvarnishapi 5.2 is not yet supported by collectd
-# Cf. https://github.com/collectd/collectd/issues/2498
-confflags += --disable-varnish
-
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
@@ -145,6 +138,7 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-nfs \
                --disable-protocols \
                --disable-serial \
+               --disable-synproxy \
                --disable-thermal \
                --disable-vmem \
                --disable-wireless
@@ -162,7 +156,12 @@ endif
 # These plugins are Intel-hardware specific.
 ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-dpdkevents \
                --disable-dpdkstat \
+               --disable-intel_pmu \
+               --disable-intel_rdt \
+               --disable-mcelog \
+               --disable-mic \
                --disable-turbostat
 endif
 
@@ -184,6 +183,11 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
+# gRPC is only available on x86, arm, ppc.
+ifeq (,$(filter amd64 arm64 armel armhf i386 ppc64el powerpc, $(DEB_BUILD_ARCH)))
+       confflags += --disable-grpc
+endif
+
 build: build-arch build-indep
 build-arch: build-stamp
 build-indep: build-stamp