Code

rules: Fix the arch selection for enabling the gRPC plugin.
[pkg-collectd.git] / debian / rules
index 9562595d1284f32522b0c44340d1b7d69b82a991..80f1bc9829f66f57eec4d1d32aa67e1ddc2ad561 100755 (executable)
@@ -183,6 +183,11 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
+# gRPC is only available on x86, arm, ppc.
+ifeq (,$(filter amd64 arm64 armel armhf i386 ppc64el powerpc, $(DEB_BUILD_ARCH)))
+       confflags += --disable-grpc
+endif
+
 build: build-arch build-indep
 build-arch: build-stamp
 build-indep: build-stamp