Code

rules: Fix the arch selection for enabling the gRPC plugin.
[pkg-collectd.git] / debian / rules
index 229a9be05aeb8e1bccc0b0ec6696ad6ddfce6384..80f1bc9829f66f57eec4d1d32aa67e1ddc2ad561 100755 (executable)
@@ -19,12 +19,6 @@ CPPFLAGS += -I$(CURDIR)/debian/include
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-error=deprecated-declarations
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
-
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
@@ -59,6 +53,7 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --without-libstatgrab \
                        --without-included-ltdl \
                        --disable-static \
+                       --disable-silent-rules \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
@@ -72,6 +67,9 @@ confflags += --disable-tape
 # libaquaero5 is required for the aquaero plugin
 confflags += --disable-aquaero
 
+# libjevents is required for the intel_pmu plugin
+confflags += --disable-intel_pmu
+
 # libmic is required for the mic plugin
 confflags += --disable-mic
 
@@ -84,17 +82,24 @@ confflags += --disable-oracle
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# libmongoc is required for the write_mongodb plugin.
-confflags += --disable-write_mongodb
-
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
+# libsigrok4 incompatible with the plugin.
+# Cf. https://github.com/collectd/collectd/issues/1574
+confflags += --disable-sigrok
+
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-barometer \
                --disable-cgroups \
+               --disable-cpusleep \
+               --disable-drbd \
                --disable-ethstat \
+               --disable-fhcount \
+               --disable-hugepages \
+               --disable-ipc \
                --disable-iptables \
                --disable-ipvs \
                --disable-lvm \
@@ -112,6 +117,10 @@ ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-pf
 endif
 
+# This plugin is Solaris-specific.
+confflags += \
+               --disable-zone
+
 # These plugins have not been ported to FreeBSD yet.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        # Work-around an incomplete check for kvm functionality
@@ -123,13 +132,13 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-conntrack \
                --disable-contextswitch \
                --disable-cpufreq \
-               --disable-disk \
                --disable-entropy \
                --disable-fscache \
                --disable-irq \
                --disable-nfs \
                --disable-protocols \
                --disable-serial \
+               --disable-synproxy \
                --disable-thermal \
                --disable-vmem \
                --disable-wireless
@@ -144,12 +153,29 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-java
 endif
 
-# This plugin is Intel-hardware specific.
+# These plugins are Intel-hardware specific.
 ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-dpdkevents \
+               --disable-dpdkstat \
+               --disable-intel_pmu \
+               --disable-intel_rdt \
+               --disable-mcelog \
+               --disable-mic \
                --disable-turbostat
 endif
 
+# This plugin is x86 and arm specific.
+ifeq (,$(filter amd64 arm64 armhf i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-xencpu
+endif
+
+# libatasmart isn't available on these platforms.
+ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += --disable-smart
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions. sparc is also having trouble building the
 # java plugin.
@@ -157,9 +183,20 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
-config.status: configure
+# gRPC is only available on x86, arm, ppc.
+ifeq (,$(filter amd64 arm64 armel armhf i386 ppc64el powerpc, $(DEB_BUILD_ARCH)))
+       confflags += --disable-grpc
+endif
+
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
        
+       dh_autoreconf
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -172,14 +209,8 @@ config.status: configure
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp: config.status
-       dh_testdir
-       
        $(MAKE)
+       dh_auto_test
        perl ./debian/bin/check_plugins.pl
        
        touch build-stamp
@@ -196,13 +227,14 @@ clean:
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        dh_install -i
        
@@ -213,14 +245,14 @@ install-indep:
                        libname=$$(basename $$lib); \
                        fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
                        for dir in $$(find . -mindepth 1 -type d); do \
-                               sed -r -i -e "s,(include\s+)\".*$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
+                               sed -r -i -e "s,(include\s+)\".*\<$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
                        done; \
                done )
 
 install-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
@@ -241,7 +273,7 @@ binary-indep: install-indep
        dh_testdir
        dh_testroot
        dh_installchangelogs -i ChangeLog
-       dh_installdocs -A -i debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -i debian/README.Debian AUTHORS README
        dh_installexamples -i contrib/examples/myplugin.c \
                contrib/examples/MyPlugin.pm
        dh_compress -i -Xexamples/
@@ -255,7 +287,7 @@ binary-arch: build install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a ChangeLog
-       dh_installdocs -A -a debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -a debian/README.Debian AUTHORS README
        dh_installdocs -a debian/NEWS.Debian debian/README.Debian.plugins
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \
@@ -275,11 +307,12 @@ binary-arch: build install-arch
                && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
                && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
-       dh_systemd_enable -pcollectd-core --name=collectd collectd.service
+       dh_systemd_enable -pcollectd-core --name=collectd
        dh_installinit -pcollectd-core --name=collectd -- defaults 95
-       dh_systemd_start
+       dh_systemd_start -pcollectd-core
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
+       dh_strip_nondeterminism -pcollectd-core
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a