Code

patches/ipvs_h_include, rules: Let the ipvs plugin use linux/ip_vs.h.
[pkg-collectd.git] / debian / rules
index be4441ed30ea95183a4f1515c941e6404570c09e..7d8139a6466575fa36f4dc9f3adb6b9b5dcfacc6 100755 (executable)
@@ -98,6 +98,11 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-netlink \
                --disable-sensors \
                --disable-vserver
+else
+       # configure is not currently able to correctly check for ip_vs.h.
+       # ipvs_h_include.dpatch takes care of using the right one. Overwriting
+       # KERNEL_DIR makes sure we don't use any kernel headers directly.
+       confflags += --enable-ipvs=force KERNEL_DIR=/usr
 endif
 
 # These plugins have not been ported to FreeBSD yet.