Code

disable building dpdkstat plugin on jessie
[pkg-collectd.git] / debian / rules
index b3325ec7870a430c57e3f380e30fb5dca1fbbdbf..5bbf9d1836b8cf109aed08e1de724956d79db05b 100755 (executable)
@@ -91,6 +91,9 @@ confflags += --disable-grpc
 # libqpos is required for the intel_rdt plugin.
 confflags += --disable-intel_rdt
 
+# libdpdk is required for the dpdkstat plugin.
+confflags += --disable-dpdkstat
+
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
@@ -161,7 +164,6 @@ endif
 # These plugins are Intel-hardware specific.
 ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
        confflags += \
-               --disable-dpdkstat \
                --disable-turbostat
 endif