Code

Merged commit 'collectd-4.10.1-1' into lenny-backports.
[pkg-collectd.git] / debian / rules
index 068edecd573446b6efa86572e323a5ea74fe83d6..46fdbf8232ae58fd3f050652734e830f1e58eef8 100755 (executable)
@@ -62,6 +62,15 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libyajl is required for the curl_json plugin.
+confflags += --disable-curl_json
+
+# libganglia >= 3 is required for the gmond plugin.
+confflags += --disable-gmond
+
+# libmemcached is required for the memcachec plugin.
+confflags += --disable-memcachec
+
 # libmodbus is required for the modbus plugin.
 confflags += --disable-modbus
 
@@ -77,6 +86,12 @@ confflags += --disable-oracle
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
+# rrdclient support in librrd is required for the rrdcached plugin.
+confflags += --disable-rrdcached
+
+# libtokyotyrant is required for the tokyotyrant plugin.
+confflags += --disable-tokyotyrant
+
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms