Code

rules: remove legacy TODO file from docs
[pkg-collectd.git] / debian / rules
index b414178b080f1fe2a99e15433cc1a2f2546db779..2f31b1b7ed63b634886b24b12039aa5d1b7bcc8b 100755 (executable)
@@ -19,12 +19,6 @@ CPPFLAGS += -I$(CURDIR)/debian/include
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-error=deprecated-declarations
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
-
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
@@ -32,7 +26,7 @@ CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
 # A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
 # Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
-ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        CPPFLAGS += -Wp,-w
 endif
 
@@ -51,8 +45,6 @@ JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
-include /usr/share/dpatch/dpatch.make
-
 confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
@@ -61,6 +53,7 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --without-libstatgrab \
                        --without-included-ltdl \
                        --disable-static \
+                       --disable-silent-rules \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
@@ -83,33 +76,32 @@ confflags += --disable-netapp
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
-# libcredis is required for the *redis plugins.
-confflags += --disable-redis --disable-write_redis
-
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# libsigrok >= 0.2.0 is required for the sigrok plugin, should arrive in unstable soon
-confflags += --disable-sigrok
-
-# varnish does not currently work with varnish4
-# (c.f. https://bugs.debian.org/745902)
-confflags += --disable-varnish
-
 # libmongoc is required for the write_mongodb plugin.
 confflags += --disable-write_mongodb
 
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# libkstat is required for the xfs_arc plugin.
-confflags += --disable-zfs-arc
+# protobuf-compiler >= 3.0.0 and libgrpc++ are required for the grpc plugin.
+confflags += --disable-grpc
+
+# libqpos is required for the intel_rdt plugin.
+confflags += --disable-intel_rdt
 
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-barometer \
                --disable-cgroups \
+               --disable-cpusleep \
+               --disable-drbd \
                --disable-ethstat \
+               --disable-fhcount \
+               --disable-hugepages \
+               --disable-ipc \
                --disable-iptables \
                --disable-ipvs \
                --disable-lvm \
@@ -119,6 +111,10 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-numa \
                --disable-sensors \
                --disable-vserver
+       # libsigrok >= 0.2.0 is required for the sigrok plugin,
+       # only available on Linux.
+       confflags += \
+               --disable-sigrok
 endif
 
 # This plugin is FreeBSD-specific.
@@ -127,6 +123,10 @@ ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-pf
 endif
 
+# This plugin is Solaris-specific.
+confflags += \
+               --disable-zone
+
 # These plugins have not been ported to FreeBSD yet.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        # Work-around an incomplete check for kvm functionality
@@ -138,7 +138,6 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-conntrack \
                --disable-contextswitch \
                --disable-cpufreq \
-               --disable-disk \
                --disable-entropy \
                --disable-fscache \
                --disable-irq \
@@ -154,11 +153,28 @@ endif
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
                --disable-gmond \
-               --disable-libvirt \
+               --disable-virt \
                --disable-tokyotyrant \
                --disable-java
 endif
 
+# This plugin is Intel-hardware specific.
+ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-turbostat
+endif
+
+# This plugin is x86 and arm specific.
+ifeq (,$(filter amd64 arm64 armhf i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-xencpu
+endif
+
+# libatasmart isn't available on these platforms.
+ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += --disable-smart
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions. sparc is also having trouble building the
 # java plugin.
@@ -166,14 +182,14 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
-config.status: configure $(DPATCH_STAMPFN)
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
        
-       ( cd debian/patches/; for patch in *; do \
-               if test "$$patch" != "00list"; then \
-                       grep "$$patch" 00list > /dev/null \
-                               || ( echo "$$patch not enabled\!"; exit 1 ); \
-               fi; done )
+       dh_autoreconf
        
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
@@ -187,19 +203,13 @@ config.status: configure $(DPATCH_STAMPFN)
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp: config.status
-       dh_testdir
-       
        $(MAKE)
+       dh_auto_test
        perl ./debian/bin/check_plugins.pl
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -211,26 +221,32 @@ clean: unpatch
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        dh_install -i
        
        # update include path for collectd header files
-       sed -r -i -e 's/include "(.*)"/include "collectd\/core\/\1"/' \
-               $(CURDIR)/debian/collectd-dev/usr/include/collectd/core/*
-       sed -r -i -e 's/"collectd\/core\/(liboconfig\/.*)"/"collectd\/\1"/' \
-               $(CURDIR)/debian/collectd-dev/usr/include/collectd/core/*
+       (       set -e; \
+               cd $(CURDIR)/debian/collectd-dev/usr/include/collectd/; \
+               for lib in $$(find . -type f -name '*.h'); do \
+                       libname=$$(basename $$lib); \
+                       fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
+                       for dir in $$(find . -mindepth 1 -type d); do \
+                               sed -r -i -e "s,(include\s+)\".*\<$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
+                       done; \
+               done )
 
 install-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
@@ -251,7 +267,7 @@ binary-indep: install-indep
        dh_testdir
        dh_testroot
        dh_installchangelogs -i ChangeLog
-       dh_installdocs -A -i debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -i debian/README.Debian AUTHORS README
        dh_installexamples -i contrib/examples/myplugin.c \
                contrib/examples/MyPlugin.pm
        dh_compress -i -Xexamples/
@@ -265,7 +281,7 @@ binary-arch: build install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a ChangeLog
-       dh_installdocs -A -a debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -a debian/README.Debian AUTHORS README
        dh_installdocs -a debian/NEWS.Debian debian/README.Debian.plugins
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \
@@ -285,9 +301,12 @@ binary-arch: build install-arch
                && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
                && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
+       dh_systemd_enable -pcollectd-core --name=collectd
        dh_installinit -pcollectd-core --name=collectd -- defaults 95
+       dh_systemd_start -pcollectd-core
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
+       dh_strip_nondeterminism -pcollectd-core
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a