Code

rules: remove legacy TODO file from docs
[pkg-collectd.git] / debian / rules
index 2ddcaa0b07c133ea7ef5dfa9a0888a7147298903..2f31b1b7ed63b634886b24b12039aa5d1b7bcc8b 100755 (executable)
@@ -12,127 +12,185 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_ARCH      ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CPPFLAGS = -I$(CURDIR)/debian/include
-CFLAGS = -Wall -g
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CPPFLAGS += -I$(CURDIR)/debian/include
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall -Wno-error=deprecated-declarations
 
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
+# A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
+# Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       CPPFLAGS += -Wp,-w
 endif
 
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
-JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
-                       $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+JAVA_ARCHDIR = $(shell /usr/share/javahelper/java-arch.sh $(DEB_BUILD_ARCH))
 ifeq (,$(JAVA_ARCHDIR))
        JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
 endif
-JAVA_HOME = /usr/lib/jvm/java-6-openjdk
+JAVA_HOME = /usr/lib/jvm/default-java
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
 JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
-include /usr/share/dpatch/dpatch.make
-
 confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --localstatedir=/var --sysconfdir=/etc \
-                       --with-perl-bindings="INSTALLDIRS=vendor" \
+                       --with-perl-bindings="INSTALLDIRS=vendor INSTALL_BASE=" \
                        --without-libstatgrab \
                        --without-included-ltdl \
                        --disable-static \
+                       --disable-silent-rules \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
-confflags += --disable-apple_sensors --disable-tape
+# MacOS only (requires IO Kit):
+confflags += --disable-apple_sensors
+# AIX only (requires perfstat):
+confflags += --disable-lpar
+# Solaris only (requires devinfo and kstat)
+confflags += --disable-tape
+
+# libaquaero5 is required for the aquaero plugin
+confflags += --disable-aquaero
+
+# libmic is required for the mic plugin
+confflags += --disable-mic
 
 # libnetapp is required for the netapp plugin.
 confflags += --disable-netapp
 
-# libowcapi is required for the onewire plugin.
-confflags += --disable-onewire
-
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
+# libmongoc is required for the write_mongodb plugin.
+confflags += --disable-write_mongodb
+
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# libkstat is required for the xfs_arc plugin.
-confflags += --disable-zfs-arc
+# protobuf-compiler >= 3.0.0 and libgrpc++ are required for the grpc plugin.
+confflags += --disable-grpc
 
-# The static library netstat cannot be linked into shared objects on some
-# architectures (see bugs #358637, #419684 and #524593 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
-       confflags += --disable-netlink
-endif
+# libqpos is required for the intel_rdt plugin.
+confflags += --disable-intel_rdt
 
 # These plugins are Linux-specific.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-barometer \
+               --disable-cgroups \
+               --disable-cpusleep \
+               --disable-drbd \
+               --disable-ethstat \
+               --disable-fhcount \
+               --disable-hugepages \
+               --disable-ipc \
                --disable-iptables \
                --disable-ipvs \
+               --disable-lvm \
+               --disable-madwifi \
+               --disable-md \
                --disable-netlink \
-               --disable-sensors
+               --disable-numa \
+               --disable-sensors \
+               --disable-vserver
+       # libsigrok >= 0.2.0 is required for the sigrok plugin,
+       # only available on Linux.
+       confflags += \
+               --disable-sigrok
+endif
+
+# This plugin is FreeBSD-specific.
+ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-pf
 endif
 
+# This plugin is Solaris-specific.
+confflags += \
+               --disable-zone
+
 # These plugins have not been ported to FreeBSD yet.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       # Work-around an incomplete check for kvm functionality
+       CPPFLAGS  += -DHAVE_STRUCT_KINFO_PROC_FREEBSD
+       confflags += --enable-processes=force
+
        confflags += \
                --disable-battery \
                --disable-conntrack \
                --disable-contextswitch \
                --disable-cpufreq \
-               --disable-disk \
                --disable-entropy \
                --disable-fscache \
                --disable-irq \
-               --disable-madwifi \
                --disable-nfs \
                --disable-protocols \
                --disable-serial \
                --disable-thermal \
                --disable-vmem \
-               --disable-vserver \
                --disable-wireless
 endif
 
 # Build-dependencies of these plugins are (not yet) available for kfreebsd.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
                --disable-gmond \
-               --disable-libvirt \
+               --disable-virt \
                --disable-tokyotyrant \
                --disable-java
 endif
 
+# This plugin is Intel-hardware specific.
+ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-turbostat
+endif
+
+# This plugin is x86 and arm specific.
+ifeq (,$(filter amd64 arm64 armhf i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-xencpu
+endif
+
+# libatasmart isn't available on these platforms.
+ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += --disable-smart
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
-# prevending testing transitions.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
+# prevending testing transitions. sparc is also having trouble building the
+# java plugin.
+ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
-config.status: configure $(DPATCH_STAMPFN)
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
        
+       dh_autoreconf
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -140,22 +198,18 @@ config.status: configure $(DPATCH_STAMPFN)
                > debian/pkgconfig/OpenIPMIpthread.pc
        
        PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
-       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
-               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )
 
-build: build-stamp
-
-build-stamp: config.status
-       dh_testdir
-       
        $(MAKE)
+       dh_auto_test
        perl ./debian/bin/check_plugins.pl
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -167,20 +221,32 @@ clean: unpatch
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        dh_install -i
+       
+       # update include path for collectd header files
+       (       set -e; \
+               cd $(CURDIR)/debian/collectd-dev/usr/include/collectd/; \
+               for lib in $$(find . -type f -name '*.h'); do \
+                       libname=$$(basename $$lib); \
+                       fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
+                       for dir in $$(find . -mindepth 1 -type d); do \
+                               sed -r -i -e "s,(include\s+)\".*\<$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
+                       done; \
+               done )
 
 install-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
@@ -201,7 +267,7 @@ binary-indep: install-indep
        dh_testdir
        dh_testroot
        dh_installchangelogs -i ChangeLog
-       dh_installdocs -A -i debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -i debian/README.Debian AUTHORS README
        dh_installexamples -i contrib/examples/myplugin.c \
                contrib/examples/MyPlugin.pm
        dh_compress -i -Xexamples/
@@ -215,16 +281,17 @@ binary-arch: build install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a ChangeLog
-       dh_installdocs -A -a debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -a debian/README.Debian AUTHORS README
        dh_installdocs -a debian/NEWS.Debian debian/README.Debian.plugins
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \
                contrib/exec-munin.conf contrib/exec-munin.px contrib/exec-smartctl \
-               contrib/exec-nagios.conf contrib/exec-nagios.px \
+               contrib/exec-nagios.conf contrib/exec-nagios.px contrib/exec-ksm.sh \
                contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
                contrib/collectd_network.py contrib/collectd_unixsock.py \
                contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               contrib/postgresql \
                debian/collectd.conf debian/filters.conf debian/thresholds.conf
        # some upstream tarballs have been built inside a dirty working dir
        ( cd debian/collectd-core/ \
@@ -234,9 +301,12 @@ binary-arch: build install-arch
                && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
                && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
+       dh_systemd_enable -pcollectd-core --name=collectd
        dh_installinit -pcollectd-core --name=collectd -- defaults 95
+       dh_systemd_start -pcollectd-core
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
+       dh_strip_nondeterminism -pcollectd-core
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a
@@ -255,5 +325,5 @@ binary-arch: build install-arch
        dh_builddeb -a
 
 binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install-indep install-arch
+.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install-indep install-arch