Code

Revert "Disable the grpc plugin for now"
[pkg-collectd.git] / debian / rules
index 094a50b908dfb42a07e2f51dfdc971f01745fa66..2dd1b357066bfcdbc918c82d148b0202f6d80edf 100755 (executable)
@@ -19,17 +19,17 @@ CPPFLAGS += -I$(CURDIR)/debian/include
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-error=deprecated-declarations
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
-
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
+# A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
+# Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       CPPFLAGS += -Wp,-w
+endif
+
 LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 # The archdir map has been copied from openjdk-6's debian/rules.
@@ -45,8 +45,6 @@ JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
-include /usr/share/dpatch/dpatch.make
-
 confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
@@ -55,6 +53,7 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --without-libstatgrab \
                        --without-included-ltdl \
                        --disable-static \
+                       --disable-silent-rules \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
@@ -74,34 +73,18 @@ confflags += --disable-mic
 # libnetapp is required for the netapp plugin.
 confflags += --disable-netapp
 
-# libowcapi is required for the onewire plugin.
-confflags += --disable-onewire
-
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
-# libcredis is required for the *redis plugins.
-confflags += --disable-redis --disable-write_redis
-
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# libsigrok >= 0.2.0 is required for the sigrok plugin, should arrive in unstable soon
-confflags += --disable-sigrok
-
-# varnish does not currently work with varnish4
-# (c.f. https://bugs.debian.org/745902)
-confflags += --disable-varnish
-
 # libmongoc is required for the write_mongodb plugin.
 confflags += --disable-write_mongodb
 
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# libkstat is required for the xfs_arc plugin.
-confflags += --disable-zfs-arc
-
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
@@ -151,25 +134,32 @@ endif
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
                --disable-gmond \
-               --disable-libvirt \
+               --disable-virt \
                --disable-tokyotyrant \
                --disable-java
 endif
 
+# This plugin is Intel-hardware specific.
+ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-turbostat
+endif
+
+# libatasmart isn't available on these platforms.
+ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += --disable-smart
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
-# prevending testing transitions.
-ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
+# prevending testing transitions. sparc is also having trouble building the
+# java plugin.
+ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
-config.status: configure $(DPATCH_STAMPFN)
+config.status: configure
        dh_testdir
-       
-       ( cd debian/patches/; for patch in *; do \
-               if test "$$patch" != "00list"; then \
-                       grep "$$patch" 00list > /dev/null \
-                               || ( echo "$$patch not enabled\!"; exit 1 ); \
-               fi; done )
+       dh_autoreconf
        
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
@@ -195,7 +185,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -207,26 +197,32 @@ clean: unpatch
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        dh_install -i
        
        # update include path for collectd header files
-       sed -r -i -e 's/include "(.*)"/include "collectd\/core\/\1"/' \
-               $(CURDIR)/debian/collectd-dev/usr/include/collectd/core/*
-       sed -r -i -e 's/"collectd\/core\/(liboconfig\/.*)"/"collectd\/\1"/' \
-               $(CURDIR)/debian/collectd-dev/usr/include/collectd/core/*
+       (       set -e; \
+               cd $(CURDIR)/debian/collectd-dev/usr/include/collectd/; \
+               for lib in $$(find . -type f -name '*.h'); do \
+                       libname=$$(basename $$lib); \
+                       fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
+                       for dir in $$(find . -mindepth 1 -type d); do \
+                               sed -r -i -e "s,(include\s+)\".*$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
+                       done; \
+               done )
 
 install-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
@@ -281,9 +277,12 @@ binary-arch: build install-arch
                && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
                && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
+       dh_systemd_enable -pcollectd-core --name=collectd
        dh_installinit -pcollectd-core --name=collectd -- defaults 95
+       dh_systemd_start -pcollectd-core
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
+       dh_strip_nondeterminism -pcollectd-core
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a