Code

disable grpc plugin on platforms lacking build dependencies
[pkg-collectd.git] / debian / rules
index 919318cf07efbb7af2dd72f4a1cd21564b01b78b..166f4c86dc0b2361d9ec7cca0d94227dc8e99a9d 100755 (executable)
@@ -67,6 +67,9 @@ confflags += --disable-tape
 # libaquaero5 is required for the aquaero plugin
 confflags += --disable-aquaero
 
+# libjevents is required for the intel_pmu plugin
+confflags += --disable-intel_pmu
+
 # libmic is required for the mic plugin
 confflags += --disable-mic
 
@@ -82,9 +85,6 @@ confflags += --disable-routeros
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# protobuf-compiler >= 3.0.0 and libgrpc++ are required for the grpc plugin.
-confflags += --disable-grpc
-
 # libsigrok4 incompatible with the plugin.
 # Cf. https://github.com/collectd/collectd/issues/1574
 confflags += --disable-sigrok
@@ -138,6 +138,7 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-nfs \
                --disable-protocols \
                --disable-serial \
+               --disable-synproxy \
                --disable-thermal \
                --disable-vmem \
                --disable-wireless
@@ -155,7 +156,12 @@ endif
 # These plugins are Intel-hardware specific.
 ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-dpdkevents \
                --disable-dpdkstat \
+               --disable-intel_pmu \
+               --disable-intel_rdt \
+               --disable-mcelog \
+               --disable-mic \
                --disable-turbostat
 endif
 
@@ -177,6 +183,10 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
+ifneq (,$(filter amd64 arm64 armel armhf i386 ppc64el powerpc, $(DEB_BUILD_ARCH)))
+       confflags += --disable-grpc
+endif
+
 build: build-arch build-indep
 build-arch: build-stamp
 build-indep: build-stamp