Code

Disable the grpc plugin for now
[pkg-collectd.git] / debian / rules
index 3960dff718620145034dd2c1062d89703aa81d33..16153dde499979c48762df61728229aecaa86a1e 100755 (executable)
@@ -19,12 +19,6 @@ CPPFLAGS += -I$(CURDIR)/debian/include
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-error=deprecated-declarations
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
-
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
@@ -91,6 +85,9 @@ confflags += --disable-write_mongodb
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
+# protobuf-compiler >= 3.0.0 is required for the grpc plugin.
+confflags += --disable-grpc
+
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
@@ -105,6 +102,10 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-numa \
                --disable-sensors \
                --disable-vserver
+       # libsigrok >= 0.2.0 is required for the sigrok plugin,
+       # only available on Linux.
+       confflags += \
+               --disable-sigrok
 endif
 
 # This plugin is FreeBSD-specific.
@@ -124,7 +125,6 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-conntrack \
                --disable-contextswitch \
                --disable-cpufreq \
-               --disable-disk \
                --disable-entropy \
                --disable-fscache \
                --disable-irq \
@@ -163,9 +163,15 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
-config.status: configure
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
        
+       dh_autoreconf
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -178,13 +184,6 @@ config.status: configure
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp: config.status
-       dh_testdir
-       
        $(MAKE)
        perl ./debian/bin/check_plugins.pl
        
@@ -202,6 +201,7 @@ clean:
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
@@ -281,7 +281,7 @@ binary-arch: build install-arch
                && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
                && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
-       dh_systemd_enable -pcollectd-core --name=collectd collectd.service
+       dh_systemd_enable -pcollectd-core --name=collectd
        dh_installinit -pcollectd-core --name=collectd -- defaults 95
        dh_systemd_start -pcollectd-core
        dh_link -a