Code

Disable the lvm plugin
[pkg-collectd.git] / debian / rules
index cac99e0d8b81fd6da2ce193d887201590ac250d3..0ec86d41ff6eb6e863d88f292322d3c1c6709d1e 100755 (executable)
@@ -82,19 +82,13 @@ confflags += --disable-routeros
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# protobuf-compiler >= 3.0.0 and libgrpc++ are required for the grpc plugin.
-confflags += --disable-grpc
-
-# libqpos is required for the intel_rdt plugin.
-confflags += --disable-intel_rdt
-
 # libsigrok4 incompatible with the plugin.
 # Cf. https://github.com/collectd/collectd/issues/1574
 confflags += --disable-sigrok
 
-# libvarnishapi 5.2 is not yet supported by collectd
-# Cf. https://github.com/collectd/collectd/issues/2498
-confflags += --disable-varnish
+# liblvm2app is deprecated.
+# https://github.com/collectd/collectd/issues/2647
+confflags += --disable-lvm
 
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
@@ -109,7 +103,6 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-ipc \
                --disable-iptables \
                --disable-ipvs \
-               --disable-lvm \
                --disable-madwifi \
                --disable-md \
                --disable-netlink \