Code

Disable the lvm plugin
[pkg-collectd.git] / debian / rules
index 0da5b2bebde227c405990e67a406900ca458dc4f..0ec86d41ff6eb6e863d88f292322d3c1c6709d1e 100755 (executable)
@@ -19,12 +19,6 @@ CPPFLAGS += -I$(CURDIR)/debian/include
 CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall -Wno-error=deprecated-declarations
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
-
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
@@ -85,20 +79,30 @@ confflags += --disable-oracle
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# libmongoc is required for the write_mongodb plugin.
-confflags += --disable-write_mongodb
-
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
+# libsigrok4 incompatible with the plugin.
+# Cf. https://github.com/collectd/collectd/issues/1574
+confflags += --disable-sigrok
+
+# liblvm2app is deprecated.
+# https://github.com/collectd/collectd/issues/2647
+confflags += --disable-lvm
+
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-barometer \
                --disable-cgroups \
+               --disable-cpusleep \
+               --disable-drbd \
                --disable-ethstat \
+               --disable-fhcount \
+               --disable-hugepages \
+               --disable-ipc \
                --disable-iptables \
                --disable-ipvs \
-               --disable-lvm \
                --disable-madwifi \
                --disable-md \
                --disable-netlink \
@@ -113,6 +117,10 @@ ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-pf
 endif
 
+# This plugin is Solaris-specific.
+confflags += \
+               --disable-zone
+
 # These plugins have not been ported to FreeBSD yet.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        # Work-around an incomplete check for kvm functionality
@@ -124,7 +132,6 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-conntrack \
                --disable-contextswitch \
                --disable-cpufreq \
-               --disable-disk \
                --disable-entropy \
                --disable-fscache \
                --disable-irq \
@@ -145,12 +152,19 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
                --disable-java
 endif
 
-# This plugin is Intel-hardware specific.
+# These plugins are Intel-hardware specific.
 ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-dpdkstat \
                --disable-turbostat
 endif
 
+# This plugin is x86 and arm specific.
+ifeq (,$(filter amd64 arm64 armhf i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-xencpu
+endif
+
 # libatasmart isn't available on these platforms.
 ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += --disable-smart
@@ -163,9 +177,15 @@ ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
-config.status: configure
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
        
+       dh_autoreconf
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -178,14 +198,8 @@ config.status: configure
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp: config.status
-       dh_testdir
-       
        $(MAKE)
+       dh_auto_test
        perl ./debian/bin/check_plugins.pl
        
        touch build-stamp
@@ -202,6 +216,7 @@ clean:
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
@@ -219,7 +234,7 @@ install-indep:
                        libname=$$(basename $$lib); \
                        fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
                        for dir in $$(find . -mindepth 1 -type d); do \
-                               sed -r -i -e "s,(include\s+)\".*$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
+                               sed -r -i -e "s,(include\s+)\".*\<$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
                        done; \
                done )
 
@@ -247,7 +262,7 @@ binary-indep: install-indep
        dh_testdir
        dh_testroot
        dh_installchangelogs -i ChangeLog
-       dh_installdocs -A -i debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -i debian/README.Debian AUTHORS README
        dh_installexamples -i contrib/examples/myplugin.c \
                contrib/examples/MyPlugin.pm
        dh_compress -i -Xexamples/
@@ -261,7 +276,7 @@ binary-arch: build install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a ChangeLog
-       dh_installdocs -A -a debian/README.Debian AUTHORS README TODO
+       dh_installdocs -A -a debian/README.Debian AUTHORS README
        dh_installdocs -a debian/NEWS.Debian debian/README.Debian.plugins
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \