Code

Disable the grpc plugin for now
[pkg-collectd.git] / debian / rules
index 3e40466d2d9a5277cb9c8b87f83a8f3cf5d75768..068b3b2bb983452a21ba7a1579702295403a7b15 100755 (executable)
@@ -12,72 +12,157 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_ARCH      ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CPPFLAGS = -I$(CURDIR)/debian/include
-CFLAGS = -Wall -g
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
 
-# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
-# however required by the perl plugin (which would otherwise be unable to find
-# symbols defined in libperl when loading perl modules that require such
-# symbols). This is a workaround for this issue.
-CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CPPFLAGS += -I$(CURDIR)/debian/include
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall -Wno-error=deprecated-declarations
 
 # Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
 # /etc/collectd would be wrong though.
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
+# A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
+# Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       CPPFLAGS += -Wp,-w
 endif
 
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = alpha=alpha arm=arm armel=arm amd64=amd64 hppa=parisc \
-                       i386=i386 lpia=i386 m68k=m68k mips=mips mipsel=mipsel \
-                       powerpc=ppc sparc=sparc s390=s390 ia64=ia64
-JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
-                       $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
-JAVA_HOME = /usr/lib/jvm/java-6-openjdk
+JAVA_ARCHDIR = $(shell /usr/share/javahelper/java-arch.sh $(DEB_BUILD_ARCH))
+ifeq (,$(JAVA_ARCHDIR))
+       JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
+endif
+JAVA_HOME = /usr/lib/jvm/default-java
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
 JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
-include /usr/share/dpatch/dpatch.make
-
 confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --localstatedir=/var --sysconfdir=/etc \
-                       --with-perl-bindings="INSTALLDIRS=vendor" \
+                       --with-perl-bindings="INSTALLDIRS=vendor INSTALL_BASE=" \
                        --without-libstatgrab \
+                       --without-included-ltdl \
+                       --disable-static \
+                       --disable-silent-rules \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
-confflags += --disable-apple_sensors --disable-tape
+# MacOS only (requires IO Kit):
+confflags += --disable-apple_sensors
+# AIX only (requires perfstat):
+confflags += --disable-lpar
+# Solaris only (requires devinfo and kstat)
+confflags += --disable-tape
 
-# libowcapi is required for the onewire plugin.
-confflags += --disable-onewire
+# libaquaero5 is required for the aquaero plugin
+confflags += --disable-aquaero
+
+# libmic is required for the mic plugin
+confflags += --disable-mic
+
+# libnetapp is required for the netapp plugin.
+confflags += --disable-netapp
 
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
-# rrdclient support in librrd is required for the rrdcached plugin.
-confflags += --disable-rrdcached
+# librouteros is required for the routeros plugin.
+confflags += --disable-routeros
+
+# libmongoc is required for the write_mongodb plugin.
+confflags += --disable-write_mongodb
 
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
-# The static library netstat cannot be linked into shared objects on some
-# architectures (see bugs #358637, #419684 and #524593 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
-       confflags += --disable-netlink
+# protobuf-compiler >= 3.0.0 is required for the grpc plugin.
+confflags += --disable-grpc
+
+# These plugins are Linux-specific.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-cgroups \
+               --disable-ethstat \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-lvm \
+               --disable-madwifi \
+               --disable-md \
+               --disable-netlink \
+               --disable-numa \
+               --disable-sensors \
+               --disable-vserver
+endif
+
+# This plugin is FreeBSD-specific.
+ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-pf
 endif
 
-config.status: configure $(DPATCH_STAMPFN)
+# These plugins have not been ported to FreeBSD yet.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       # Work-around an incomplete check for kvm functionality
+       CPPFLAGS  += -DHAVE_STRUCT_KINFO_PROC_FREEBSD
+       confflags += --enable-processes=force
+
+       confflags += \
+               --disable-battery \
+               --disable-conntrack \
+               --disable-contextswitch \
+               --disable-cpufreq \
+               --disable-disk \
+               --disable-entropy \
+               --disable-fscache \
+               --disable-irq \
+               --disable-nfs \
+               --disable-protocols \
+               --disable-serial \
+               --disable-thermal \
+               --disable-vmem \
+               --disable-wireless
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-gmond \
+               --disable-virt \
+               --disable-tokyotyrant \
+               --disable-java
+endif
+
+# This plugin is Intel-hardware specific.
+ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-turbostat
+endif
+
+# libatasmart isn't available on these platforms.
+ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += --disable-smart
+endif
+
+# The hppa buildds currently do not keep up with Java related stuff, thus
+# prevending testing transitions. sparc is also having trouble building the
+# java plugin.
+ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
+       confflags += --disable-java
+endif
+
+config.status: configure
        dh_testdir
+       dh_autoreconf
        
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
@@ -86,11 +171,14 @@ config.status: configure $(DPATCH_STAMPFN)
                > debian/pkgconfig/OpenIPMIpthread.pc
        
        PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
-       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
-               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
-               JAVA_LDFLAGS="$(JAVA_LDFLAGS)"
+       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+               JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
+               || ( status=$$?; cat config.log; exit $$status )
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -100,7 +188,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -112,20 +200,32 @@ clean: unpatch
        
        rm -rf debian/pkgconfig
        
+       dh_autoreconf_clean
        dh_clean
        debconf-updatepo
 
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        dh_install -i
+       
+       # update include path for collectd header files
+       (       set -e; \
+               cd $(CURDIR)/debian/collectd-dev/usr/include/collectd/; \
+               for lib in $$(find . -type f -name '*.h'); do \
+                       libname=$$(basename $$lib); \
+                       fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
+                       for dir in $$(find . -mindepth 1 -type d); do \
+                               sed -r -i -e "s,(include\s+)\".*$$libname\",\1\"$$fullpath\"," $$dir/*.h; \
+                       done; \
+               done )
 
 install-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
@@ -138,9 +238,9 @@ install-arch: build
        
        perl ./debian/bin/gen_plugin_deps.pl
        
-       mkdir -p debian/collectd/usr/share/lintian/overrides/
-       cp debian/collectd.overrides \
-               debian/collectd/usr/share/lintian/overrides/collectd
+       mkdir -p debian/collectd-core/usr/share/lintian/overrides/
+       cp debian/collectd-core.overrides \
+               debian/collectd-core/usr/share/lintian/overrides/collectd-core
 
 binary-indep: install-indep
        dh_testdir
@@ -165,34 +265,44 @@ binary-arch: build install-arch
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \
                contrib/exec-munin.conf contrib/exec-munin.px contrib/exec-smartctl \
-               contrib/exec-nagios.conf contrib/exec-nagios.px \
+               contrib/exec-nagios.conf contrib/exec-nagios.px contrib/exec-ksm.sh \
                contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
-               contrib/collectd-network.py contrib/collectd-unixsock.py \
-               contrib/snmp-probe-host.px contrib/GenericJMX.conf
+               contrib/collectd_network.py contrib/collectd_unixsock.py \
+               contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               contrib/postgresql \
+               debian/collectd.conf debian/filters.conf debian/thresholds.conf
        # some upstream tarballs have been built inside a dirty working dir
-       ( cd debian/collectd/usr/share/doc/collectd/examples/collection3/ \
+       ( cd debian/collectd-core/ \
+               && cd usr/share/doc/collectd-core/examples/collection3/ \
                && rm -f bin/foo bin/test_config.px etc/collection4.conf \
                && rm -f lib/Collectd/Graph.pm lib/Collectd/Graph/Data.pm \
                && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
                && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
-       dh_installinit -a -- defaults 95
+       dh_systemd_enable -pcollectd-core --name=collectd
+       dh_installinit -pcollectd-core --name=collectd -- defaults 95
+       dh_systemd_start -pcollectd-core
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
+       dh_strip_nondeterminism -pcollectd-core
        dh_compress -a -Xexamples/
        dh_fixperms -a
        dh_makeshlibs -a
        dh_installdeb -a
+       dh_shlibdeps -a -Ncollectd-core -Ncollectd
        dpkg-shlibdeps -Tdebian/collectd.substvars \
-               -dDepends debian/collectd/usr/sbin/* \
-                       debian/collectd/usr/lib/collectd/rrdtool.so \
-               -dRecommends debian/collectd/usr/lib/collectd/*.so
-       dh_shlibdeps -a -Ncollectd
+               -dDepends debian/collectd-core/usr/lib/collectd/rrdtool.so
+       dpkg-shlibdeps -Tdebian/collectd-core.substvars \
+               -dDepends debian/collectd-core/usr/sbin/* \
+               -dSuggests debian/collectd-core/usr/lib/collectd/*.so
+       grep shlibs:Suggests debian/collectd-core.substvars \
+               | sed -e 's/shlibs:Suggests/shlibs:Recommends/' \
+               >> debian/collectd.substvars
        dh_gencontrol -a
        dh_md5sums -a
        dh_builddeb -a
 
 binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install-indep install-arch
+.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install-indep install-arch