Code

work around liblvm2app depreciation
[pkg-collectd.git] / debian / patches / liblvm2app_depreciation_warning.patch
diff --git a/debian/patches/liblvm2app_depreciation_warning.patch b/debian/patches/liblvm2app_depreciation_warning.patch
new file mode 100644 (file)
index 0000000..e8bc582
--- /dev/null
@@ -0,0 +1,17 @@
+Description: mute liblvm2app depreciation warning
+Forwarded: https://github.com/collectd/collectd/issues/2647
+Author: Christian Ehrhardt <christian.ehrhardt@canonical.com>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=881641
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1042,7 +1042,7 @@ endif
+ if BUILD_PLUGIN_LVM
+ pkglib_LTLIBRARIES += lvm.la
+ lvm_la_SOURCES = src/lvm.c
+-lvm_la_CPPFLAGS = $(AM_CPPFLAGS) $(BUILD_WITH_LIBLVM2APP_CPPFLAGS)
++lvm_la_CPPFLAGS = $(AM_CPPFLAGS) $(BUILD_WITH_LIBLVM2APP_CPPFLAGS) -Wno-cpp
+ lvm_la_LDFLAGS = $(PLUGIN_LDFLAGS) $(BUILD_WITH_LIBLVM2APP_LDFLAGS)
+ lvm_la_LIBADD = $(BUILD_WITH_LIBLVM2APP_LIBS)
+ endif
+