Code

Removed netrc-doc.dpatch which has been merged upstream.
[pkg-cadaver.git] / debian / rules
index 1fdc8d05ff47d09bb3b492363b6eb1189231c799..797557b7b628cb305784228a7108f7a9384b4af1 100755 (executable)
@@ -23,11 +23,17 @@ endif
 
 $(BUILDDIR)/config.status: configure
        dh_testdir
+       
+       for file in config.guess config.sub; do \
+               mv $$file $$file.upstream; \
+               ln -s /usr/share/misc/$$file .; \
+       done
+       
        [ -e $(BUILDDIR) ] || mkdir $(BUILDDIR)
        cd $(BUILDDIR) && CFLAGS="$(CFLAGS)" ../../configure \
                        --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr --mandir=\$${prefix}/share/man \
-                       --enable-warnings --enable-netrc --without-ssl
+                       --enable-warnings --enable-netrc --with-ssl=gnutls
 
 build: build-stamp
 
@@ -47,6 +53,13 @@ clean:
        
        rm -rf $(BUILDDIR)
        
+       for file in config.guess config.sub; do \
+               if [ -e $$file.upstream ]; then \
+                       rm -f $$file; \
+                       mv $$file.upstream $$file; \
+               fi \
+       done
+       
        dh_clean
 
 install: build