Code

patches: Added bts770693_timestamps.
[pkg-collectd.git] / debian / rules
index 11ef4ccdd3c3a90e013afef2717b268acb4ba6f4..b0dd9fde0334b8b2b35933d8db76d97e226482c2 100755 (executable)
@@ -30,6 +30,12 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
+# A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
+# Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       CPPFLAGS += -Wp,-w
+endif
+
 LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 # The archdir map has been copied from openjdk-6's debian/rules.
@@ -154,8 +160,9 @@ ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
 endif
 
 # The hppa buildds currently do not keep up with Java related stuff, thus
-# prevending testing transitions.
-ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
+# prevending testing transitions. sparc is also having trouble building the
+# java plugin.
+ifneq (,$(filter hppa sparc, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif