Code

Re-enabled the modbus and AMQP plugins.
[pkg-collectd.git] / debian / rules
index 2df30d93620a9997738175723e74fd917ced6d41..af70f20dc99c346a4e4cc896643194aa948b98b2 100755 (executable)
@@ -12,9 +12,11 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_ARCH      ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 CPPFLAGS += -I$(CURDIR)/debian/include
-CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
 CFLAGS += -Wall
 
 # There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
@@ -28,7 +30,7 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-LDFLAGS = `dpkg-buildflags --get LDFLAGS`
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 # The archdir map has been copied from openjdk-6's debian/rules.
 JAVA_ARCHDIR = $(shell /usr/share/javahelper/java-arch.sh $(DEB_BUILD_ARCH))
@@ -56,10 +58,12 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
-confflags += --disable-apple_sensors --disable-tape
-
-# libmodbus is required for the modbus plugin.
-confflags += --disable-modbus
+# MacOS only (requires IO Kit):
+confflags += --disable-apple_sensors
+# AIX only (requires perfstat):
+confflags += --disable-lpar
+# Solaris only (requires devinfo and kstat)
+confflags += --disable-tape
 
 # libnetapp is required for the netapp plugin.
 confflags += --disable-netapp
@@ -70,9 +74,15 @@ confflags += --disable-onewire
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
+# libcredis is required for the *redis plugins.
+confflags += --disable-redis --disable-write_redis
+
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
+# libmongoc is required for the write_mongodb plugin.
+confflags += --disable-write_mongodb
+
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
@@ -88,16 +98,29 @@ endif
 # These plugins are Linux-specific.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
+               --disable-ethstat \
                --disable-iptables \
                --disable-ipvs \
                --disable-madwifi \
+               --disable-md \
                --disable-netlink \
+               --disable-numa \
                --disable-sensors \
                --disable-vserver
 endif
 
+# This plugin is FreeBSD-specific.
+ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-pf
+endif
+
 # These plugins have not been ported to FreeBSD yet.
 ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       # Work-around an incomplete check for kvm functionality
+       CPPFLAGS  += -DHAVE_STRUCT_KINFO_PROC_FREEBSD
+       confflags += --enable-processes=force
+
        confflags += \
                --disable-battery \
                --disable-conntrack \
@@ -197,6 +220,14 @@ install-arch: build
        rm -f debian/tmp/usr/lib/libcollectdclient.la
        rm -f debian/tmp/etc/collectd.conf
        
+       # this was broken by passing INSTALL_BASE rather than PREFIX to
+       # Makefile.PL
+       install -d -m 755 debian/tmp/usr/share/man/man3
+       mv debian/tmp/usr/man/man3/Collectd::Unixsock.3pm \
+               debian/tmp/usr/share/man/man3/
+       install -d -m 755 debian/tmp/usr/share/
+       mv debian/tmp/usr/lib/perl5 debian/tmp/usr/share/
+       
        dh_install -a --sourcedir=$(CURDIR)/debian/tmp --fail-missing
        
        perl ./debian/bin/gen_plugin_deps.pl
@@ -228,11 +259,12 @@ binary-arch: build install-arch
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \
                contrib/exec-munin.conf contrib/exec-munin.px contrib/exec-smartctl \
-               contrib/exec-nagios.conf contrib/exec-nagios.px \
+               contrib/exec-nagios.conf contrib/exec-nagios.px contrib/exec-ksm.sh \
                contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
                contrib/collectd_network.py contrib/collectd_unixsock.py \
                contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               contrib/postgresql \
                debian/collectd.conf debian/filters.conf debian/thresholds.conf
        # some upstream tarballs have been built inside a dirty working dir
        ( cd debian/collectd-core/ \