Code

rules: Install debian/collectd.conf as an example into "collectd-core".
[pkg-collectd.git] / debian / rules
index e3783986a998cfd12a50abfa3020691e964d692d..9b46ea37fa3aaadd028222686e13ef22661a5f4d 100755 (executable)
@@ -1,7 +1,7 @@
-#!/usr/bin/make -f
+#! /usr/bin/make -f
 # debian/rules for collectd
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -12,34 +12,96 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_ARCH      ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
+CPPFLAGS = -I$(CURDIR)/debian/include
 CFLAGS = -Wall -g
 
+# There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
+# however required by the perl plugin (which would otherwise be unable to find
+# symbols defined in libperl when loading perl modules that require such
+# symbols). This is a workaround for this issue.
+CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
+
+# Upstream defaults to ${sysconfdir}/collectd.conf. Setting ${sysconfdir} to
+# /etc/collectd would be wrong though.
+CPPFLAGS += -UCONFIGFILE
+CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
+
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
+# The archdir map has been copied from openjdk-6's debian/rules.
+JAVA_ARCHDIR_MAP = alpha=alpha arm=arm armel=arm amd64=amd64 hppa=parisc \
+                       i386=i386 lpia=i386 m68k=m68k mips=mips mipsel=mipsel \
+                       powerpc=ppc sparc=sparc s390=s390 ia64=ia64
+JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
+                       $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+JAVA_HOME = /usr/lib/jvm/java-6-openjdk
+JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
+
+JAVAC = $(JAVA_HOME)/bin/javac
+JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
+JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
+
 include /usr/share/dpatch/dpatch.make
 
 confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --localstatedir=/var --sysconfdir=/etc \
-                       --enable-debug
+                       --with-perl-bindings="INSTALLDIRS=vendor" \
+                       --without-libstatgrab \
+                       --disable-static \
+                       --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
-# The static libraries iptc and upsclient cannot be used on 64bit systems
-# (see bugs #358637 and #419684 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64))
-       confflags += --disable-iptables --disable-nut
+# libowcapi is required for the onewire plugin.
+confflags += --disable-onewire
+
+# libclntsh is required for the oracle plugin.
+confflags += --disable-oracle
+
+# rrdclient support in librrd is required for the rrdcached plugin.
+confflags += --disable-rrdcached
+
+# libtokyotyrant is required for the tokyotyrant plugin.
+confflags += --disable-tokyotyrant
+
+# xmms1 is required for the xmms plugin.
+confflags += --disable-xmms
+
+# libkstat is required for the xfs_arc plugin.
+confflags += --disable-zfs-arc
+
+# The static library netstat cannot be linked into shared objects on some
+# architectures (see bugs #358637, #419684 and #524593 for more details).
+ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
+       confflags += --disable-netlink
+endif
+
+# The hppa buildds currently do not keep up with Java related stuff, thus
+# prevending testing transitions.
+ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
+       confflags += --disable-java
 endif
 
 config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure $(confflags)
+       
+       # This is a work-around for #474087 (broken openipmi .pc files).
+       mkdir debian/pkgconfig
+       sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
+               /usr/lib/pkgconfig/OpenIPMIpthread.pc \
+               > debian/pkgconfig/OpenIPMIpthread.pc
+       
+       PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
+       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
+               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+               JAVA_LDFLAGS="$(JAVA_LDFLAGS)"
 
 build: build-stamp
 
@@ -47,7 +109,7 @@ build-stamp: config.status
        dh_testdir
        
        $(MAKE)
-       perl ./debian/check_plugins.pl
+       perl ./debian/bin/check_plugins.pl
        
        touch build-stamp
 
@@ -56,9 +118,14 @@ clean: unpatch
        dh_testroot
        rm -f build-stamp
        
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
        
-       dh_clean 
+       rm -f debian/README.Debian.plugins
+       rm -f src/*.1 src/*.5
+       
+       rm -rf debian/pkgconfig
+       
+       dh_clean
        debconf-updatepo
 
 install-indep:
@@ -66,54 +133,36 @@ install-indep:
        dh_testroot
        dh_clean -k
        dh_installdirs -i
-       
-       include_dir=debian/collectd-dev/usr/include/collectd/ \
-               && mkdir -p $$include_dir \
-               && cp src/*.h $$include_dir
+       dh_install -i
 
 install-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs -a
        
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/collectd
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
-       rm -f debian/collectd/usr/lib/collectd/*.la
+       rm -f debian/tmp/usr/lib/collectd/*.la
+       rm -f debian/tmp/usr/lib/libcollectdclient.la
+       rm -f debian/tmp/etc/collectd.conf
        
-       rm -f debian/collectd/etc/collectd.conf
-       install -D -m 0644 debian/collectd.conf \
-               debian/collectd/etc/collectd/collectd.conf
-       install -m 0644 debian/collection.conf \
-               debian/collectd/etc/collectd/collection.conf
+       dh_install -a --sourcedir=$(CURDIR)/debian/tmp --fail-missing
        
-       for PLUGIN in apache dns mysql perl ping sensors; do \
-               plugin_dir=debian/collectd-$$PLUGIN/usr/lib/collectd/; \
-               manpage=debian/collectd/usr/share/man/man5/collectd-$$PLUGIN.5; \
-               man_dir=debian/collectd-$$PLUGIN/usr/share/man/man5/; \
-               \
-               mkdir -p $$plugin_dir; \
-               mv debian/collectd/usr/lib/collectd/$$PLUGIN.so $$plugin_dir; \
-               \
-               if [ -e $$manpage ]; then \
-                       mkdir -p $$man_dir; \
-                       mv $$manpage $$man_dir; \
-               fi \
-       done
+       perl ./debian/bin/gen_plugin_deps.pl
        
-       mkdir -p debian/collectd/usr/lib/collectd/utils/
-       for UTIL in extractDS.px migrate-3-4.px; do \
-               cp contrib/$$UTIL debian/collectd/usr/lib/collectd/utils/; \
-       done
+       mkdir -p debian/collectd-core/usr/share/lintian/overrides/
+       cp debian/collectd-core.overrides \
+               debian/collectd-core/usr/share/lintian/overrides/collectd-core
 
 binary-indep: install-indep
        dh_testdir
        dh_testroot
        dh_installchangelogs -i ChangeLog
        dh_installdocs -A -i debian/README.Debian AUTHORS README TODO
-       dh_installexamples -i debian/examples/myplugin.c \
-               debian/examples/MyPlugin.pm
-       dh_compress -i
+       dh_installexamples -i contrib/examples/myplugin.c \
+               contrib/examples/MyPlugin.pm
+       dh_compress -i -Xexamples/
        dh_fixperms -i
        dh_installdeb -i
        dh_gencontrol -i
@@ -125,18 +174,40 @@ binary-arch: build install-arch
        dh_testroot
        dh_installchangelogs -a ChangeLog
        dh_installdocs -A -a debian/README.Debian AUTHORS README TODO
-       dh_installdocs -a debian/NEWS.Debian
+       dh_installdocs -a debian/NEWS.Debian debian/README.Debian.plugins
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
-               contrib/PerlLib/ contrib/SpamAssassin/ contrib/iptables/
+               contrib/collection3/ contrib/php-collection/ \
+               contrib/exec-munin.conf contrib/exec-munin.px contrib/exec-smartctl \
+               contrib/exec-nagios.conf contrib/exec-nagios.px \
+               contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
+               contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
+               contrib/collectd_network.py contrib/collectd_unixsock.py \
+               contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               debian/collectd.conf
+       # some upstream tarballs have been built inside a dirty working dir
+       ( cd debian/collectd-core/ \
+               && cd usr/share/doc/collectd-core/examples/collection3/ \
+               && rm -f bin/foo bin/test_config.px etc/collection4.conf \
+               && rm -f lib/Collectd/Graph.pm lib/Collectd/Graph/Data.pm \
+               && rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
+               && rm -f lib/Collectd/Graph/MetaData.pm )
        dh_installdebconf -a
-       dh_installinit -a -- defaults 95
-       dh_installman -a src/collectd.1 src/collectd.conf.5
+       dh_installinit -pcollectd-core --name=collectd -- defaults 95
        dh_link -a
        dh_strip -a --dbg-package=collectd-dbg
-       dh_compress -a
+       dh_compress -a -Xexamples/
        dh_fixperms -a
+       dh_makeshlibs -a
        dh_installdeb -a
-       dh_shlibdeps -a
+       dh_shlibdeps -a -Ncollectd-core -Ncollectd
+       dh_shlibdeps -pcollectd \
+               -- -edebian/collectd-core/usr/lib/collectd/rrdtool.so
+       dpkg-shlibdeps -Tdebian/collectd-core.substvars \
+               -dDepends debian/collectd-core/usr/sbin/* \
+               -dSuggests debian/collectd-core/usr/lib/collectd/*.so
+       grep shlibs:Suggests debian/collectd-core.substvars \
+               | sed -e 's/shlibs:Suggests/shlibs:Recommends/' \
+               >> debian/collectd.substvars
        dh_gencontrol -a
        dh_md5sums -a
        dh_builddeb -a