Code

Updated copyright for 0.23.3.
[pkg-cadaver.git] / debian / rules
index 797557b7b628cb305784228a7108f7a9384b4af1..906dba62f7e6119325563b7fbd6144805503dbc4 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for cadaver
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -21,7 +21,9 @@ else
        CFLAGS += -O2
 endif
 
-$(BUILDDIR)/config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+$(BUILDDIR)/config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
        for file in config.guess config.sub; do \
@@ -46,12 +48,13 @@ build-stamp: $(BUILDDIR)/config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
        
        rm -rf $(BUILDDIR)
+       rm -f po/*.gmo
        
        for file in config.guess config.sub; do \
                if [ -e $$file.upstream ]; then \