Code

Updated copyright for 0.23.3.
[pkg-cadaver.git] / debian / rules
index 1fdc8d05ff47d09bb3b492363b6eb1189231c799..906dba62f7e6119325563b7fbd6144805503dbc4 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for cadaver
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -21,13 +21,21 @@ else
        CFLAGS += -O2
 endif
 
-$(BUILDDIR)/config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+$(BUILDDIR)/config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
+       
+       for file in config.guess config.sub; do \
+               mv $$file $$file.upstream; \
+               ln -s /usr/share/misc/$$file .; \
+       done
+       
        [ -e $(BUILDDIR) ] || mkdir $(BUILDDIR)
        cd $(BUILDDIR) && CFLAGS="$(CFLAGS)" ../../configure \
                        --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr --mandir=\$${prefix}/share/man \
-                       --enable-warnings --enable-netrc --without-ssl
+                       --enable-warnings --enable-netrc --with-ssl=gnutls
 
 build: build-stamp
 
@@ -40,12 +48,20 @@ build-stamp: $(BUILDDIR)/config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
        
        rm -rf $(BUILDDIR)
+       rm -f po/*.gmo
+       
+       for file in config.guess config.sub; do \
+               if [ -e $$file.upstream ]; then \
+                       rm -f $$file; \
+                       mv $$file.upstream $$file; \
+               fi \
+       done
        
        dh_clean