Code

control, rules: Disabled plugins on kfreebsd whose build-deps are n/a (yet).
[pkg-collectd.git] / debian / rules
index f5b027bf5318819faba8a84374066a729fdc284d..3cbe40c695269789f502bd8e677e49218b68bf62 100755 (executable)
@@ -33,11 +33,12 @@ else
 endif
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = alpha=alpha arm=arm armel=arm amd64=amd64 hppa=parisc \
-                       i386=i386 lpia=i386 m68k=m68k mips=mips mipsel=mipsel \
-                       powerpc=ppc sparc=sparc s390=s390 ia64=ia64
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
 JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
                        $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+ifeq (,$(JAVA_ARCHDIR))
+       JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
+endif
 JAVA_HOME = /usr/lib/jvm/java-6-openjdk
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
@@ -60,12 +61,18 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libnetapp is required for the netapp plugin.
+confflags += --disable-netapp
+
 # libowcapi is required for the onewire plugin.
 confflags += --disable-onewire
 
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
+# librouteros is required for the routeros plugin.
+confflags += --disable-routeros
+
 # rrdclient support in librrd is required for the rrdcached plugin.
 confflags += --disable-rrdcached
 
@@ -84,6 +91,22 @@ ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
        confflags += --disable-netlink
 endif
 
+# These plugins are Linux-specific.
+ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+       confflags += \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-netlink
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+       confflags += \
+               --disable-gmond \
+               --disable-libvirt \
+               --disable-java
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions.
 ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
@@ -185,7 +208,7 @@ binary-arch: build install-arch
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
                contrib/collectd_network.py contrib/collectd_unixsock.py \
                contrib/snmp-probe-host.px contrib/GenericJMX.conf \
-               debian/collectd.conf
+               debian/collectd.conf debian/filters.conf debian/thresholds.conf
        # some upstream tarballs have been built inside a dirty working dir
        ( cd debian/collectd-core/ \
                && cd usr/share/doc/collectd-core/examples/collection3/ \