Code

bts566199….dpatch: Added missing @DPATCH@ template foo.
[pkg-collectd.git] / debian / rules
index 8a74be97804c436802660b1f3f84bc4023ccff40..2ddcaa0b07c133ea7ef5dfa9a0888a7147298903 100755 (executable)
@@ -33,11 +33,12 @@ else
 endif
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = alpha=alpha arm=arm armel=arm amd64=amd64 hppa=parisc \
-                       i386=i386 lpia=i386 m68k=m68k mips=mips mipsel=mipsel \
-                       powerpc=ppc sparc=sparc s390=s390 ia64=ia64
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
 JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
                        $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+ifeq (,$(JAVA_ARCHDIR))
+       JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
+endif
 JAVA_HOME = /usr/lib/jvm/java-6-openjdk
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
@@ -69,11 +70,8 @@ confflags += --disable-onewire
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
-# rrdclient support in librrd is required for the rrdcached plugin.
-confflags += --disable-rrdcached
-
-# libtokyotyrant is required for the tokyotyrant plugin.
-confflags += --disable-tokyotyrant
+# librouteros is required for the routeros plugin.
+confflags += --disable-routeros
 
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
@@ -87,6 +85,45 @@ ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
        confflags += --disable-netlink
 endif
 
+# These plugins are Linux-specific.
+ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+       confflags += \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-netlink \
+               --disable-sensors
+endif
+
+# These plugins have not been ported to FreeBSD yet.
+ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+       confflags += \
+               --disable-battery \
+               --disable-conntrack \
+               --disable-contextswitch \
+               --disable-cpufreq \
+               --disable-disk \
+               --disable-entropy \
+               --disable-fscache \
+               --disable-irq \
+               --disable-madwifi \
+               --disable-nfs \
+               --disable-protocols \
+               --disable-serial \
+               --disable-thermal \
+               --disable-vmem \
+               --disable-vserver \
+               --disable-wireless
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+       confflags += \
+               --disable-gmond \
+               --disable-libvirt \
+               --disable-tokyotyrant \
+               --disable-java
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions.
 ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))