Code

collectd.conf, control, rules: Disabled the "gmond" plugin.
[pkg-collectd.git] / debian / rules
index d944454855f460409f2afb6541bc520abc350225..2c484b3b06d2c0eacad36e1035803aa0850787a9 100755 (executable)
@@ -26,18 +26,19 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = alpha=alpha arm=arm armel=arm amd64=amd64 hppa=parisc \
-                       i386=i386 lpia=i386 m68k=m68k mips=mips mipsel=mipsel \
-                       powerpc=ppc sparc=sparc s390=s390 ia64=ia64 sh4=sh4
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
 JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
                        $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+ifeq (,$(JAVA_ARCHDIR))
+       JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
+endif
 JAVA_HOME = /usr/lib/jvm/java-6-openjdk
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
@@ -60,6 +61,9 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libganglia >= 3 is required for the gmond plugin.
+confflags += --disable-gmond
+
 # libnetapp is required for the netapp plugin.
 confflags += --disable-netapp
 
@@ -72,12 +76,6 @@ confflags += --disable-oracle
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# rrdclient support in librrd is required for the rrdcached plugin.
-confflags += --disable-rrdcached
-
-# libtokyotyrant is required for the tokyotyrant plugin.
-confflags += --disable-tokyotyrant
-
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
@@ -86,19 +84,64 @@ confflags += --disable-zfs-arc
 
 # The static library netstat cannot be linked into shared objects on some
 # architectures (see bugs #358637, #419684 and #524593 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
+ifneq (,$(filter alpha amd64 hppa ia64 ppc64 mips mipsel, $(DEB_BUILD_ARCH)))
        confflags += --disable-netlink
 endif
 
+# These plugins are Linux-specific.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-madwifi \
+               --disable-netlink \
+               --disable-sensors \
+               --disable-vserver
+endif
+
+# These plugins have not been ported to FreeBSD yet.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-battery \
+               --disable-conntrack \
+               --disable-contextswitch \
+               --disable-cpufreq \
+               --disable-disk \
+               --disable-entropy \
+               --disable-fscache \
+               --disable-irq \
+               --disable-nfs \
+               --disable-protocols \
+               --disable-serial \
+               --disable-thermal \
+               --disable-vmem \
+               --disable-wireless
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-gmond \
+               --disable-libvirt \
+               --disable-tokyotyrant \
+               --disable-java
+endif
+
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
+ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
 config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
+       ( cd debian/patches/; for patch in *; do \
+               if test "$$patch" != "00list"; then \
+                       grep "$$patch" 00list > /dev/null \
+                               || ( echo "$$patch not enabled\!"; exit 1 ); \
+               fi; done )
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \