Code

rules: Disable the aquaero plugin which requires libaquaero5.
[pkg-collectd.git] / debian / rules
index a55d09c862ccb508219760087b2c2150401d1b0d..1ee9bfeaec5103edc1e4fd53e24678f8f649923b 100755 (executable)
@@ -12,8 +12,12 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_ARCH      ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CPPFLAGS = -I$(CURDIR)/debian/include
-CFLAGS = -Wall -g
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CPPFLAGS += -I$(CURDIR)/debian/include
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall
 
 # There is no way to tell lt_dlopen() to use the RTLD_GLOBAL flag which is
 # however required by the perl plugin (which would otherwise be unable to find
@@ -26,23 +30,18 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
-JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
-                       $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
+JAVA_ARCHDIR = $(shell /usr/share/javahelper/java-arch.sh $(DEB_BUILD_ARCH))
 ifeq (,$(JAVA_ARCHDIR))
        JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
 endif
-JAVA_HOME = /usr/lib/jvm/java-6-openjdk
+JAVA_HOME = /usr/lib/jvm/default-java
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
 JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
@@ -59,7 +58,18 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
                        --enable-all-plugins
 
 # These plugins do not provide any functionality under Linux.
-confflags += --disable-apple_sensors --disable-tape
+# MacOS only (requires IO Kit):
+confflags += --disable-apple_sensors
+# AIX only (requires perfstat):
+confflags += --disable-lpar
+# Solaris only (requires devinfo and kstat)
+confflags += --disable-tape
+
+# libaquaero5 is required for the aquaero plugin
+confflags += --disable-aquaero
+
+# libmic is required for the mic plugin
+confflags += --disable-mic
 
 # libnetapp is required for the netapp plugin.
 confflags += --disable-netapp
@@ -70,14 +80,17 @@ confflags += --disable-onewire
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
+# libcredis is required for the *redis plugins.
+confflags += --disable-redis --disable-write_redis
+
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# rrdclient support in librrd is required for the rrdcached plugin.
-confflags += --disable-rrdcached
+# libsigrok >= 0.2.0 is required for the sigrok plugin, should arrive in unstable soon
+confflags += --disable-sigrok
 
-# libtokyotyrant is required for the tokyotyrant plugin.
-confflags += --disable-tokyotyrant
+# libmongoc is required for the write_mongodb plugin.
+confflags += --disable-write_mongodb
 
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
@@ -85,21 +98,73 @@ confflags += --disable-xmms
 # libkstat is required for the xfs_arc plugin.
 confflags += --disable-zfs-arc
 
-# The static library netstat cannot be linked into shared objects on some
-# architectures (see bugs #358637, #419684 and #524593 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
-       confflags += --disable-netlink
+# These plugins are Linux-specific.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-ethstat \
+               --disable-iptables \
+               --disable-ipvs \
+               --disable-madwifi \
+               --disable-md \
+               --disable-netlink \
+               --disable-numa \
+               --disable-sensors \
+               --disable-vserver
+endif
+
+# This plugin is FreeBSD-specific.
+ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-pf
+endif
+
+# These plugins have not been ported to FreeBSD yet.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       # Work-around an incomplete check for kvm functionality
+       CPPFLAGS  += -DHAVE_STRUCT_KINFO_PROC_FREEBSD
+       confflags += --enable-processes=force
+
+       confflags += \
+               --disable-battery \
+               --disable-conntrack \
+               --disable-contextswitch \
+               --disable-cpufreq \
+               --disable-disk \
+               --disable-entropy \
+               --disable-fscache \
+               --disable-irq \
+               --disable-nfs \
+               --disable-protocols \
+               --disable-serial \
+               --disable-thermal \
+               --disable-vmem \
+               --disable-wireless
+endif
+
+# Build-dependencies of these plugins are (not yet) available for kfreebsd.
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       confflags += \
+               --disable-gmond \
+               --disable-libvirt \
+               --disable-tokyotyrant \
+               --disable-java
 endif
 
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
+ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
 config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
+       ( cd debian/patches/; for patch in *; do \
+               if test "$$patch" != "00list"; then \
+                       grep "$$patch" 00list > /dev/null \
+                               || ( echo "$$patch not enabled\!"; exit 1 ); \
+               fi; done )
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -107,12 +172,14 @@ config.status: configure $(DPATCH_STAMPFN)
                > debian/pkgconfig/OpenIPMIpthread.pc
        
        PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
-       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
-               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+       ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -187,11 +254,12 @@ binary-arch: build install-arch
        dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
                contrib/collection3/ contrib/php-collection/ \
                contrib/exec-munin.conf contrib/exec-munin.px contrib/exec-smartctl \
-               contrib/exec-nagios.conf contrib/exec-nagios.px \
+               contrib/exec-nagios.conf contrib/exec-nagios.px contrib/exec-ksm.sh \
                contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
                contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
                contrib/collectd_network.py contrib/collectd_unixsock.py \
                contrib/snmp-probe-host.px contrib/GenericJMX.conf \
+               contrib/postgresql \
                debian/collectd.conf debian/filters.conf debian/thresholds.conf
        # some upstream tarballs have been built inside a dirty working dir
        ( cd debian/collectd-core/ \
@@ -222,5 +290,5 @@ binary-arch: build install-arch
        dh_builddeb -a
 
 binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install-indep install-arch
+.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install-indep install-arch