Code

collectd.conf, control, rules: Re-enabled rrdcached plugin.
[pkg-collectd.git] / debian / rules
index e9487ac8771f8499533922519a0094f2c70f9363..1020b9d8549d31d69d7def4d5e0d392873ccda65 100755 (executable)
@@ -33,7 +33,7 @@ else
 endif
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc sh4=sh
 JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
                        $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
 ifeq (,$(JAVA_ARCHDIR))
@@ -43,6 +43,7 @@ JAVA_HOME = /usr/lib/jvm/java-6-openjdk
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
 JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
@@ -61,6 +62,15 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libyajl is required for the curl_json plugin.
+confflags += --disable-curl_json
+
+# libganglia >= 3 is required for the gmond plugin.
+confflags += --disable-gmond
+
+# libmemcached is required for the memcachec plugin.
+confflags += --disable-memcachec
+
 # libmodbus is required for the modbus plugin.
 confflags += --disable-modbus
 
@@ -73,9 +83,15 @@ confflags += --disable-onewire
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
+# protobuf is required for the pinba plugin.
+confflags += --disable-pinba
+
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
+# libtokyotyrant is required for the tokyotyrant plugin.
+confflags += --disable-tokyotyrant
+
 # xmms1 is required for the xmms plugin.
 confflags += --disable-xmms
 
@@ -150,7 +166,7 @@ config.status: configure $(DPATCH_STAMPFN)
        
        PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
        ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
-               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )