Code

collectd.conf, control, rules: Re-enabled rrdcached plugin.
[pkg-collectd.git] / debian / rules
index cb1e229a380471d7750833dee89cca08f9f61ea0..1020b9d8549d31d69d7def4d5e0d392873ccda65 100755 (executable)
@@ -26,14 +26,14 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
 # The archdir map has been copied from openjdk-6's debian/rules.
-JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc
+JAVA_ARCHDIR_MAP = armel=arm hppa=parisc lpia=i386 powerpc=ppc sh4=sh
 JAVA_ARCHDIR = $(strip $(patsubst $(DEB_BUILD_ARCH)=%, %, \
                        $(filter $(DEB_BUILD_ARCH)=%, $(JAVA_ARCHDIR_MAP))))
 ifeq (,$(JAVA_ARCHDIR))
@@ -43,6 +43,7 @@ JAVA_HOME = /usr/lib/jvm/java-6-openjdk
 JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
 
 JAVAC = $(JAVA_HOME)/bin/javac
+JAR = $(JAVA_HOME)/bin/jar
 JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
 JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
 
@@ -61,6 +62,18 @@ confflags = --host=$(DEB_HOST_GNU_TYPE) \
 # These plugins do not provide any functionality under Linux.
 confflags += --disable-apple_sensors --disable-tape
 
+# libyajl is required for the curl_json plugin.
+confflags += --disable-curl_json
+
+# libganglia >= 3 is required for the gmond plugin.
+confflags += --disable-gmond
+
+# libmemcached is required for the memcachec plugin.
+confflags += --disable-memcachec
+
+# libmodbus is required for the modbus plugin.
+confflags += --disable-modbus
+
 # libnetapp is required for the netapp plugin.
 confflags += --disable-netapp
 
@@ -70,12 +83,12 @@ confflags += --disable-onewire
 # libclntsh is required for the oracle plugin.
 confflags += --disable-oracle
 
+# protobuf is required for the pinba plugin.
+confflags += --disable-pinba
+
 # librouteros is required for the routeros plugin.
 confflags += --disable-routeros
 
-# rrdclient support in librrd is required for the rrdcached plugin.
-confflags += --disable-rrdcached
-
 # libtokyotyrant is required for the tokyotyrant plugin.
 confflags += --disable-tokyotyrant
 
@@ -87,21 +100,23 @@ confflags += --disable-zfs-arc
 
 # The static library netstat cannot be linked into shared objects on some
 # architectures (see bugs #358637, #419684 and #524593 for more details).
-ifneq (,$(findstring $(DEB_BUILD_ARCH),alpha amd64 hppa ia64 ppc64 mips mipsel))
+ifneq (,$(filter alpha amd64 hppa ia64 ppc64 mips mipsel, $(DEB_BUILD_ARCH)))
        confflags += --disable-netlink
 endif
 
 # These plugins are Linux-specific.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
                --disable-iptables \
                --disable-ipvs \
+               --disable-madwifi \
                --disable-netlink \
-               --disable-sensors
+               --disable-sensors \
+               --disable-vserver
 endif
 
 # These plugins have not been ported to FreeBSD yet.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
                --disable-battery \
                --disable-conntrack \
@@ -111,33 +126,38 @@ ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
                --disable-entropy \
                --disable-fscache \
                --disable-irq \
-               --disable-madwifi \
                --disable-nfs \
                --disable-protocols \
                --disable-serial \
                --disable-thermal \
                --disable-vmem \
-               --disable-vserver \
                --disable-wireless
 endif
 
 # Build-dependencies of these plugins are (not yet) available for kfreebsd.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
        confflags += \
                --disable-gmond \
                --disable-libvirt \
+               --disable-tokyotyrant \
                --disable-java
 endif
 
 # The hppa buildds currently do not keep up with Java related stuff, thus
 # prevending testing transitions.
-ifneq (,$(findstring $(DEB_BUILD_ARCH),hppa))
+ifneq (,$(filter hppa, $(DEB_BUILD_ARCH)))
        confflags += --disable-java
 endif
 
 config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        
+       ( cd debian/patches/; for patch in *; do \
+               if test "$$patch" != "00list"; then \
+                       grep "$$patch" 00list > /dev/null \
+                               || ( echo "$$patch not enabled\!"; exit 1 ); \
+               fi; done )
+       
        # This is a work-around for #474087 (broken openipmi .pc files).
        mkdir debian/pkgconfig
        sed -re 's/^(Requires:.*) pthread(.*)$$/\1\2/' \
@@ -146,7 +166,7 @@ config.status: configure $(DPATCH_STAMPFN)
        
        PKG_CONFIG_PATH="$(CURDIR)/debian/pkgconfig:$$PKG_CONFIG_PATH" \
        ./configure $(confflags) CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" \
-               JAVAC="$(JAVAC)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
+               JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
                JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
                || ( status=$$?; cat config.log; exit $$status )