Code

build system: Define the 'version' target in the toplevel Makefile.
[template.git] / src / Makefile.am
index 4787460c94a618241a765019907c7dca76d8883a..86e78ee586f511a7c64fb41cbe161ca3712f117f 100644 (file)
@@ -14,10 +14,6 @@ fb_SOURCES = fb.c foobar.h
 fb_CFLAGS = $(AM_CFLAGS) -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\""
 fb_LDADD = libfoobar.la
 
-../version: FORCE
-       @# As a side-effect, this updates ../version.
-       @echo Building $(PACKAGE_NAME) version $$( cd .. && ./version-gen.sh )
-
 fb_features.h: fb_features.h.in ../version
        source ../version; sed \
            -e "s/@FB_VERSION_MAJOR@/$$VERSION_MAJOR/g" \