Code

Merged branch 'master' of git://git.tokkee.org/sysdb.
[sysdb.git] / t / Makefile.am
index bfeadcfc13d7cab9485c6ae20eaa310b99f46e1e..f40d16f97a50f141e5d68e6efe806e5c4c10d174 100644 (file)
@@ -2,7 +2,8 @@ EXTRA_DIST = \
                coverage.sh \
                integration/simple_config.sh \
                integration/simple_query.sh \
-               integration/test_lib.sh
+               integration/test_lib.sh \
+               valgrind.suppress
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
@@ -11,7 +12,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
 TESTS =
 check_PROGRAMS =
-noinst_LTLIBRARIES =
+check_LTLIBRARIES =
 
 #
 # unit tests
@@ -57,7 +58,7 @@ if INTEGRATION_TESTING
 TESTS += integration/simple_config.sh integration/simple_query.sh
 endif
 
-noinst_LTLIBRARIES += integration/mock_plugin.la
+check_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
 # -rpath is a work-around to enforce a shared library
 integration_mock_plugin_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \