Code

t/integration/store.sh: Add integration tests for the STORE command.
[sysdb.git] / t / Makefile.am
index 3f1fd4bc20179d0ac8dc2f2b4da763d788b664ee..e2cde1d429503feed3dc0c4430f170dd85350d03 100644 (file)
@@ -1,9 +1,13 @@
 EXTRA_DIST = \
                coverage.sh \
                testwrapper.sh \
+               integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
-               integration/query.sh \
+               integration/store.sh \
+               integration/query_fetch.sh \
+               integration/query_list.sh \
+               integration/query_timeseries.sh \
                integration/matching.sh \
                integration/filter.sh \
                integration/test_lib.sh \
@@ -35,9 +39,10 @@ UNIT_TESTS = \
                unit/core/store_test \
                unit/core/time_test \
                unit/frontend/connection_test \
-               unit/frontend/parser_test \
                unit/frontend/query_test \
                unit/frontend/sock_test \
+               unit/parser/ast_test \
+               unit/parser/ast_test \
                unit/parser/parser_test \
                unit/utils/avltree_test \
                unit/utils/channel_test \
@@ -90,10 +95,6 @@ unit_frontend_connection_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/conne
 unit_frontend_connection_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_connection_test_LDADD = $(UNIT_TEST_LDADD)
 
-unit_frontend_parser_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/parser_test.c
-unit_frontend_parser_test_CFLAGS = $(UNIT_TEST_CFLAGS)
-unit_frontend_parser_test_LDADD = $(UNIT_TEST_LDADD)
-
 unit_frontend_query_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/query_test.c
 unit_frontend_query_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_query_test_LDADD = $(UNIT_TEST_LDADD)
@@ -102,6 +103,10 @@ unit_frontend_sock_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/sock_test.c
 unit_frontend_sock_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_sock_test_LDADD = $(UNIT_TEST_LDADD)
 
+unit_parser_ast_test_SOURCES = $(UNIT_TEST_SOURCES) unit/parser/ast_test.c
+unit_parser_ast_test_CFLAGS = $(UNIT_TEST_CFLAGS)
+unit_parser_ast_test_LDADD = $(UNIT_TEST_LDADD)
+
 unit_parser_parser_test_SOURCES = $(UNIT_TEST_SOURCES) unit/parser/parser_test.c
 unit_parser_parser_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_parser_parser_test_LDADD = $(UNIT_TEST_LDADD)
@@ -147,6 +152,7 @@ INTEGRATION_TESTS = \
                integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
+               integration/store.sh \
                integration/query_fetch.sh \
                integration/query_list.sh \
                integration/query_timeseries.sh \