Code

t/integration/store.sh: Add integration tests for the STORE command.
[sysdb.git] / t / Makefile.am
index 3218c7b5aafc01d5ac2726c6d5df018dd9471134..e2cde1d429503feed3dc0c4430f170dd85350d03 100644 (file)
@@ -1,9 +1,13 @@
 EXTRA_DIST = \
                coverage.sh \
                testwrapper.sh \
+               integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
-               integration/query.sh \
+               integration/store.sh \
+               integration/query_fetch.sh \
+               integration/query_list.sh \
+               integration/query_timeseries.sh \
                integration/matching.sh \
                integration/filter.sh \
                integration/test_lib.sh \
@@ -12,7 +16,8 @@ EXTRA_DIST = \
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
 AM_LDFLAGS = @COVERAGE_LDFLAGS@
-AM_CPPFLAGS = -I$(top_srcdir)/src/include
+AM_CPPFLAGS = -I$(top_builddir)/src/include \
+               -I$(top_srcdir)/src/include -I$(top_srcdir)/src
 
 TESTS =
 check_PROGRAMS =
@@ -22,20 +27,23 @@ check_LTLIBRARIES =
 # unit tests
 #
 
-LOG_COMPILER = $(abs_srcdir)/testwrapper.sh
+LOG_COMPILER = env VPATH=$(VPATH) $(abs_srcdir)/testwrapper.sh
 
 if UNIT_TESTING
 UNIT_TESTS = \
                unit/core/data_test \
                unit/core/object_test \
+               unit/core/store_expr_test \
                unit/core/store_json_test \
                unit/core/store_lookup_test \
                unit/core/store_test \
                unit/core/time_test \
                unit/frontend/connection_test \
-               unit/frontend/parser_test \
                unit/frontend/query_test \
                unit/frontend/sock_test \
+               unit/parser/ast_test \
+               unit/parser/ast_test \
+               unit/parser/parser_test \
                unit/utils/avltree_test \
                unit/utils/channel_test \
                unit/utils/dbi_test \
@@ -63,6 +71,10 @@ unit_core_object_test_SOURCES = $(UNIT_TEST_SOURCES) unit/core/object_test.c
 unit_core_object_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_core_object_test_LDADD = $(UNIT_TEST_LDADD)
 
+unit_core_store_expr_test_SOURCES = $(UNIT_TEST_SOURCES) unit/core/store_expr_test.c
+unit_core_store_expr_test_CFLAGS = $(UNIT_TEST_CFLAGS)
+unit_core_store_expr_test_LDADD = $(UNIT_TEST_LDADD)
+
 unit_core_store_json_test_SOURCES = $(UNIT_TEST_SOURCES) unit/core/store_json_test.c
 unit_core_store_json_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_core_store_json_test_LDADD = $(UNIT_TEST_LDADD)
@@ -83,10 +95,6 @@ unit_frontend_connection_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/conne
 unit_frontend_connection_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_connection_test_LDADD = $(UNIT_TEST_LDADD)
 
-unit_frontend_parser_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/parser_test.c
-unit_frontend_parser_test_CFLAGS = $(UNIT_TEST_CFLAGS)
-unit_frontend_parser_test_LDADD = $(UNIT_TEST_LDADD)
-
 unit_frontend_query_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/query_test.c
 unit_frontend_query_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_query_test_LDADD = $(UNIT_TEST_LDADD)
@@ -95,6 +103,14 @@ unit_frontend_sock_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/sock_test.c
 unit_frontend_sock_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_sock_test_LDADD = $(UNIT_TEST_LDADD)
 
+unit_parser_ast_test_SOURCES = $(UNIT_TEST_SOURCES) unit/parser/ast_test.c
+unit_parser_ast_test_CFLAGS = $(UNIT_TEST_CFLAGS)
+unit_parser_ast_test_LDADD = $(UNIT_TEST_LDADD)
+
+unit_parser_parser_test_SOURCES = $(UNIT_TEST_SOURCES) unit/parser/parser_test.c
+unit_parser_parser_test_CFLAGS = $(UNIT_TEST_CFLAGS)
+unit_parser_parser_test_LDADD = $(UNIT_TEST_LDADD)
+
 unit_utils_avltree_test_SOURCES = $(UNIT_TEST_SOURCES) unit/utils/avltree_test.c
 unit_utils_avltree_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_utils_avltree_test_LDADD = $(UNIT_TEST_LDADD)
@@ -133,9 +149,13 @@ endif
 
 if INTEGRATION_TESTING
 INTEGRATION_TESTS = \
+               integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
-               integration/query.sh \
+               integration/store.sh \
+               integration/query_fetch.sh \
+               integration/query_list.sh \
+               integration/query_timeseries.sh \
                integration/matching.sh \
                integration/filter.sh