Code

t/integration/store.sh: Add integration tests for the STORE command.
[sysdb.git] / t / Makefile.am
index 1b2960d982defe93128dcb43cad4d3d59f2d3be8..e2cde1d429503feed3dc0c4430f170dd85350d03 100644 (file)
@@ -1,9 +1,13 @@
 EXTRA_DIST = \
                coverage.sh \
                testwrapper.sh \
+               integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
-               integration/query.sh \
+               integration/store.sh \
+               integration/query_fetch.sh \
+               integration/query_list.sh \
+               integration/query_timeseries.sh \
                integration/matching.sh \
                integration/filter.sh \
                integration/test_lib.sh \
@@ -35,7 +39,6 @@ UNIT_TESTS = \
                unit/core/store_test \
                unit/core/time_test \
                unit/frontend/connection_test \
-               unit/frontend/parser_test \
                unit/frontend/query_test \
                unit/frontend/sock_test \
                unit/parser/ast_test \
@@ -92,10 +95,6 @@ unit_frontend_connection_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/conne
 unit_frontend_connection_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_connection_test_LDADD = $(UNIT_TEST_LDADD)
 
-unit_frontend_parser_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/parser_test.c
-unit_frontend_parser_test_CFLAGS = $(UNIT_TEST_CFLAGS)
-unit_frontend_parser_test_LDADD = $(UNIT_TEST_LDADD)
-
 unit_frontend_query_test_SOURCES = $(UNIT_TEST_SOURCES) unit/frontend/query_test.c
 unit_frontend_query_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_frontend_query_test_LDADD = $(UNIT_TEST_LDADD)
@@ -153,6 +152,7 @@ INTEGRATION_TESTS = \
                integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
+               integration/store.sh \
                integration/query_fetch.sh \
                integration/query_list.sh \
                integration/query_timeseries.sh \