Code

parser_test: Added various tests for STORE commands.
[sysdb.git] / t / Makefile.am
index 971b58126d1d756e8fba5f13e5be4977f74a519d..cff09200d359f11a93a0211ac44c14b7a7180728 100644 (file)
@@ -1,8 +1,12 @@
 EXTRA_DIST = \
                coverage.sh \
-               integration/simple_config.sh \
-               integration/simple_query.sh \
-               integration/test_lib.sh
+               testwrapper.sh \
+               integration/config.sh \
+               integration/query.sh \
+               integration/matching.sh \
+               integration/filter.sh \
+               integration/test_lib.sh \
+               valgrind.suppress
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
@@ -11,14 +15,18 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
 TESTS =
 check_PROGRAMS =
-noinst_LTLIBRARIES =
+check_LTLIBRARIES =
 
 #
 # unit tests
 #
 
+LOG_COMPILER = $(abs_srcdir)/testwrapper.sh
+
+if UNIT_TESTING
 TESTS += unit/libsysdb_test unit/libsysdb_net_test
 check_PROGRAMS += unit/libsysdb_test unit/libsysdb_net_test
+endif
 
 unit_libsysdb_test_SOURCES = \
                unit/libsysdb_test.c unit/libsysdb_test.h \
@@ -26,14 +34,18 @@ unit_libsysdb_test_SOURCES = \
                unit/core/data_test.c \
                unit/core/object_test.c \
                unit/core/store_test.c \
+               unit/core/store_json_test.c \
                unit/core/store_lookup_test.c \
                unit/core/time_test.c \
                unit/frontend/connection_test.c \
                unit/frontend/parser_test.c \
                unit/frontend/sock_test.c \
+               unit/utils/avltree_test.c \
                unit/utils/channel_test.c \
                unit/utils/dbi_test.c \
                unit/utils/llist_test.c \
+               unit/utils/os_test.c \
+               unit/utils/proto_test.c \
                unit/utils/strbuf_test.c
 unit_libsysdb_test_CFLAGS = $(AM_CFLAGS) @CHECK_CFLAGS@ -I$(top_srcdir)/t/unit
 unit_libsysdb_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
@@ -51,13 +63,25 @@ unit_libsysdb_net_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
 # integration tests
 #
 
-TESTS += integration/simple_config.sh integration/simple_query.sh
+if INTEGRATION_TESTING
+TESTS += \
+               integration/config.sh \
+               integration/query.sh \
+               integration/matching.sh \
+               integration/filter.sh
+endif
 
-noinst_LTLIBRARIES += integration/mock_plugin.la
+check_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
 # -rpath is a work-around to enforce a shared library
 integration_mock_plugin_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
                -rpath /nonexistent
 
+check_LTLIBRARIES += integration/mock_timeseries.la
+integration_mock_timeseries_la_SOURCES = integration/mock_timeseries.c
+# -rpath is a work-around to enforce a shared library
+integration_mock_timeseries_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
+               -rpath /nonexistent
+
 test: check