Code

store: Include update interval in the JSON serialization.
[sysdb.git] / t / Makefile.am
index 1e4419dd7fcf053fae573e60278ce82520397ece..c63a2bb21d0c8f9a8e1ee25836723266f70fbebe 100644 (file)
@@ -1,11 +1,22 @@
-AM_CFLAGS = @STRICT_CFLAGS@
-AM_CPPFLAGS = -I$(top_builddir)/src/include
+EXTRA_DIST = coverage.sh
+
+# coverage related flags are only set when gcov is enabled
+AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
+AM_LDFLAGS = @COVERAGE_LDFLAGS@
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
 TESTS = libsysdb_test libsysdb_net_test
 check_PROGRAMS = libsysdb_test libsysdb_net_test
 
 libsysdb_test_SOURCES = \
                libsysdb_test.c libsysdb_test.h \
+               core/data_test.c \
+               core/object_test.c \
+               core/store_test.c \
+               core/store_lookup_test.c \
+               core/time_test.c \
+               frontend/parser_test.c \
+               frontend/sock_test.c \
                utils/channel_test.c \
                utils/dbi_test.c \
                utils/llist_test.c \