Code

integration tests: Run all invocations through valgrind's memcheck.
[sysdb.git] / t / Makefile.am
index b40d090e3be773b4339830e61f088781f16b75b1..971b58126d1d756e8fba5f13e5be4977f74a519d 100644 (file)
@@ -1,4 +1,8 @@
-EXTRA_DIST = coverage.sh
+EXTRA_DIST = \
+               coverage.sh \
+               integration/simple_config.sh \
+               integration/simple_query.sh \
+               integration/test_lib.sh
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
@@ -47,7 +51,7 @@ unit_libsysdb_net_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
 # integration tests
 #
 
-TESTS += integration/simple_config.sh
+TESTS += integration/simple_config.sh integration/simple_query.sh
 
 noinst_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c