Code

integration tests: Run all invocations through valgrind's memcheck.
[sysdb.git] / t / Makefile.am
index 4764a6ed276d5fdd9a71469975816f75388dd5e3..971b58126d1d756e8fba5f13e5be4977f74a519d 100644 (file)
@@ -1,12 +1,24 @@
-EXTRA_DIST = coverage.sh
+EXTRA_DIST = \
+               coverage.sh \
+               integration/simple_config.sh \
+               integration/simple_query.sh \
+               integration/test_lib.sh
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
 AM_LDFLAGS = @COVERAGE_LDFLAGS@
 AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
-TESTS = unit/libsysdb_test unit/libsysdb_net_test
-check_PROGRAMS = unit/libsysdb_test unit/libsysdb_net_test
+TESTS =
+check_PROGRAMS =
+noinst_LTLIBRARIES =
+
+#
+# unit tests
+#
+
+TESTS += unit/libsysdb_test unit/libsysdb_net_test
+check_PROGRAMS += unit/libsysdb_test unit/libsysdb_net_test
 
 unit_libsysdb_test_SOURCES = \
                unit/libsysdb_test.c unit/libsysdb_test.h \
@@ -35,5 +47,17 @@ endif
 unit_libsysdb_net_test_CFLAGS = $(AM_CFLAGS) @CHECK_CFLAGS@ -I$(top_srcdir)/t/unit
 unit_libsysdb_net_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
 
+#
+# integration tests
+#
+
+TESTS += integration/simple_config.sh integration/simple_query.sh
+
+noinst_LTLIBRARIES += integration/mock_plugin.la
+integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
+# -rpath is a work-around to enforce a shared library
+integration_mock_plugin_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
+               -rpath /nonexistent
+
 test: check