Code

Added the SysDB homepage to all manpages.
[sysdb.git] / t / Makefile.am
index 43d24d986ba541a8092a4448c50c94974a439502..61328af23eded6b65a7e3a94f86b926d9e7d584f 100644 (file)
@@ -1,5 +1,6 @@
 EXTRA_DIST = \
                coverage.sh \
+               testwrapper.sh \
                integration/simple_config.sh \
                integration/simple_query.sh \
                integration/test_lib.sh \
@@ -12,12 +13,14 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
 TESTS =
 check_PROGRAMS =
-noinst_LTLIBRARIES =
+check_LTLIBRARIES =
 
 #
 # unit tests
 #
 
+LOG_COMPILER = $(abs_srcdir)/testwrapper.sh
+
 if UNIT_TESTING
 TESTS += unit/libsysdb_test unit/libsysdb_net_test
 check_PROGRAMS += unit/libsysdb_test unit/libsysdb_net_test
@@ -34,9 +37,11 @@ unit_libsysdb_test_SOURCES = \
                unit/frontend/connection_test.c \
                unit/frontend/parser_test.c \
                unit/frontend/sock_test.c \
+               unit/utils/avltree_test.c \
                unit/utils/channel_test.c \
                unit/utils/dbi_test.c \
                unit/utils/llist_test.c \
+               unit/utils/os_test.c \
                unit/utils/strbuf_test.c
 unit_libsysdb_test_CFLAGS = $(AM_CFLAGS) @CHECK_CFLAGS@ -I$(top_srcdir)/t/unit
 unit_libsysdb_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
@@ -58,7 +63,7 @@ if INTEGRATION_TESTING
 TESTS += integration/simple_config.sh integration/simple_query.sh
 endif
 
-noinst_LTLIBRARIES += integration/mock_plugin.la
+check_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
 # -rpath is a work-around to enforce a shared library
 integration_mock_plugin_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \