Code

plugin: Make sdb_plugin_info_t public.
[sysdb.git] / t / Makefile.am
index 4764a6ed276d5fdd9a71469975816f75388dd5e3..5de153f16e5718cd9c316c5077dabb8ea5b54868 100644 (file)
@@ -1,12 +1,27 @@
-EXTRA_DIST = coverage.sh
+EXTRA_DIST = \
+               coverage.sh \
+               integration/simple_config.sh \
+               integration/simple_query.sh \
+               integration/test_lib.sh \
+               valgrind.suppress
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
 AM_LDFLAGS = @COVERAGE_LDFLAGS@
 AM_CPPFLAGS = -I$(top_srcdir)/src/include
 
-TESTS = unit/libsysdb_test unit/libsysdb_net_test
-check_PROGRAMS = unit/libsysdb_test unit/libsysdb_net_test
+TESTS =
+check_PROGRAMS =
+check_LTLIBRARIES =
+
+#
+# unit tests
+#
+
+if UNIT_TESTING
+TESTS += unit/libsysdb_test unit/libsysdb_net_test
+check_PROGRAMS += unit/libsysdb_test unit/libsysdb_net_test
+endif
 
 unit_libsysdb_test_SOURCES = \
                unit/libsysdb_test.c unit/libsysdb_test.h \
@@ -22,6 +37,7 @@ unit_libsysdb_test_SOURCES = \
                unit/utils/channel_test.c \
                unit/utils/dbi_test.c \
                unit/utils/llist_test.c \
+               unit/utils/os_test.c \
                unit/utils/strbuf_test.c
 unit_libsysdb_test_CFLAGS = $(AM_CFLAGS) @CHECK_CFLAGS@ -I$(top_srcdir)/t/unit
 unit_libsysdb_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
@@ -35,5 +51,19 @@ endif
 unit_libsysdb_net_test_CFLAGS = $(AM_CFLAGS) @CHECK_CFLAGS@ -I$(top_srcdir)/t/unit
 unit_libsysdb_net_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
 
+#
+# integration tests
+#
+
+if INTEGRATION_TESTING
+TESTS += integration/simple_config.sh integration/simple_query.sh
+endif
+
+check_LTLIBRARIES += integration/mock_plugin.la
+integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
+# -rpath is a work-around to enforce a shared library
+integration_mock_plugin_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
+               -rpath /nonexistent
+
 test: check