Code

store_lookup_test: Verify that NULL is not a valid attribute name.
[sysdb.git] / t / Makefile.am
index 562ee1da7f9c3ea6b296a380aa74b9fdf4af1c7c..43d24d986ba541a8092a4448c50c94974a439502 100644 (file)
@@ -1,4 +1,9 @@
-EXTRA_DIST = coverage.sh
+EXTRA_DIST = \
+               coverage.sh \
+               integration/simple_config.sh \
+               integration/simple_query.sh \
+               integration/test_lib.sh \
+               valgrind.suppress
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
@@ -13,8 +18,10 @@ noinst_LTLIBRARIES =
 # unit tests
 #
 
+if UNIT_TESTING
 TESTS += unit/libsysdb_test unit/libsysdb_net_test
 check_PROGRAMS += unit/libsysdb_test unit/libsysdb_net_test
+endif
 
 unit_libsysdb_test_SOURCES = \
                unit/libsysdb_test.c unit/libsysdb_test.h \
@@ -47,7 +54,9 @@ unit_libsysdb_net_test_LDADD = $(top_builddir)/src/libsysdb.la @CHECK_LIBS@
 # integration tests
 #
 
+if INTEGRATION_TESTING
 TESTS += integration/simple_config.sh integration/simple_query.sh
+endif
 
 noinst_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c