Code

build system: Fix VPATH (out-of-tree) builds.
[sysdb.git] / t / Makefile.am
index f01e35bc9e9d35bd247a71548b0ba5dd9cba5154..039995cdc3fde350004d564c143544a6410aec1e 100644 (file)
@@ -12,7 +12,8 @@ EXTRA_DIST = \
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@
 AM_LDFLAGS = @COVERAGE_LDFLAGS@
-AM_CPPFLAGS = -I$(top_srcdir)/src/include
+AM_CPPFLAGS = -I$(top_builddir)/src/include \
+               -I$(top_srcdir)/src/include -I$(top_srcdir)/src
 
 TESTS =
 check_PROGRAMS =
@@ -22,12 +23,13 @@ check_LTLIBRARIES =
 # unit tests
 #
 
-LOG_COMPILER = $(abs_srcdir)/testwrapper.sh
+LOG_COMPILER = env VPATH=$(VPATH) $(abs_srcdir)/testwrapper.sh
 
 if UNIT_TESTING
 UNIT_TESTS = \
                unit/core/data_test \
                unit/core/object_test \
+               unit/core/store_expr_test \
                unit/core/store_json_test \
                unit/core/store_lookup_test \
                unit/core/store_test \
@@ -63,6 +65,10 @@ unit_core_object_test_SOURCES = $(UNIT_TEST_SOURCES) unit/core/object_test.c
 unit_core_object_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_core_object_test_LDADD = $(UNIT_TEST_LDADD)
 
+unit_core_store_expr_test_SOURCES = $(UNIT_TEST_SOURCES) unit/core/store_expr_test.c
+unit_core_store_expr_test_CFLAGS = $(UNIT_TEST_CFLAGS)
+unit_core_store_expr_test_LDADD = $(UNIT_TEST_LDADD)
+
 unit_core_store_json_test_SOURCES = $(UNIT_TEST_SOURCES) unit/core/store_json_test.c
 unit_core_store_json_test_CFLAGS = $(UNIT_TEST_CFLAGS)
 unit_core_store_json_test_LDADD = $(UNIT_TEST_LDADD)
@@ -132,13 +138,18 @@ endif
 #
 
 if INTEGRATION_TESTING
-TESTS += \
+INTEGRATION_TESTS = \
+               integration/client.sh \
                integration/config.sh \
                integration/ssl.sh \
-               integration/query.sh \
+               integration/query_fetch.sh \
+               integration/query_list.sh \
+               integration/query_timeseries.sh \
                integration/matching.sh \
                integration/filter.sh
 
+TESTS += $(INTEGRATION_TESTS)
+
 check_LTLIBRARIES += integration/mock_plugin.la
 integration_mock_plugin_la_SOURCES = integration/mock_plugin.c
 # -rpath is a work-around to enforce a shared library