Code

core: Don't leak memory upon an error in the collector loop.
[sysdb.git] / src / Makefile.am
index cdadd60a80932f37df8a0dddf987ecbcb045249e..f6df34a25e7cdd16ac80ea4a06564ddf689cd785 100644 (file)
@@ -66,7 +66,9 @@ libsysdb_la_SOURCES = \
                core/object.c include/core/object.h \
                core/plugin.c include/core/plugin.h \
                core/store.c include/core/store.h \
-               include/core/data.h \
+               core/store-private.h \
+               core/store_lookup.c \
+               core/data.c include/core/data.h \
                frontend/connection.c include/frontend/connection.h \
                frontend/connection-private.h \
                frontend/parser.c include/frontend/parser.h \
@@ -103,7 +105,9 @@ libsysdb_scanner_la_SOURCES = tools/sysdb/scanner.l
 libsysdb_scanner_la_CFLAGS = -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\""
 sysdb_SOURCES = tools/sysdb/main.c include/client/sysdb.h \
                tools/sysdb/command.c tools/sysdb/command.h \
-               tools/sysdb/input.c tools/sysdb/input.h
+               tools/sysdb/input.c tools/sysdb/input.h \
+               core/object.c include/core/object.h \
+               utils/llist.c include/utils/llist.h
 sysdb_CFLAGS = -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\"" \
                $(AM_CFLAGS) @READLINE_CFLAGS@
 sysdb_LDADD = libsysdb_scanner.la libsysdbclient.la @READLINE_LIBS@