Code

proto: Let unmarshal functions return the number of bytes processed.
[sysdb.git] / src / Makefile.am
index a69769d72dd21f159fea34daee3b6d540cae1bb3..ca558623722049c61fb8808d035aaf1867bdaa37 100644 (file)
@@ -2,6 +2,7 @@ SUBDIRS = liboconfig
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@ @PROFILING_CFLAGS@
+AM_CXXFLAGS = @STRICT_CXXFLAGS@ @COVERAGE_CFLAGS@ @PROFILING_CFLAGS@
 AM_LDFLAGS = @COVERAGE_LDFLAGS@ @PROFILING_LDFLAGS@
 AM_CPPFLAGS  = -I"${top_srcdir}/src/include"
 AM_CPPFLAGS += -DSYSCONFDIR='"${sysconfdir}"'
@@ -72,9 +73,11 @@ libsysdb_la_SOURCES = \
                core/store.c include/core/store.h \
                core/store-private.h \
                core/store_expr.c \
+               core/store_json.c \
                core/store_lookup.c \
                core/data.c include/core/data.h \
                core/timeseries.c include/core/timeseries.h \
+               frontend/analyzer.c \
                frontend/connection.c include/frontend/connection.h \
                frontend/connection-private.h \
                frontend/parser.c include/frontend/parser.h \
@@ -116,7 +119,8 @@ sysdb_SOURCES = tools/sysdb/main.c include/client/sysdb.h \
                tools/sysdb/command.c tools/sysdb/command.h \
                tools/sysdb/input.c tools/sysdb/input.h \
                core/object.c include/core/object.h \
-               utils/llist.c include/utils/llist.h
+               utils/llist.c include/utils/llist.h \
+               utils/os.c include/utils/os.h
 sysdb_CFLAGS = -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\"" \
                $(AM_CFLAGS) @READLINE_CFLAGS@
 sysdb_LDADD = libsysdb_scanner.la libsysdbclient.la @READLINE_LIBS@
@@ -168,6 +172,14 @@ sysdbd_LDADD += -dlopen plugins/backend/collectd/unixsock.la
 sysdbd_DEPENDENCIES += plugins/backend/collectd/unixsock.la
 endif
 
+if BUILD_PLUGIN_FACTER
+pkgbackendlib_LTLIBRARIES += plugins/backend/facter.la
+plugins_backend_facter_la_SOURCES = plugins/backend/facter.cc
+plugins_backend_facter_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version -lfacter
+sysdbd_LDADD += -dlopen plugins/backend/facter.la
+sysdbd_DEPENDENCIES += plugins/backend/facter.la
+endif
+
 if BUILD_PLUGIN_MKLIVESTATUS
 pkgbackendlib_LTLIBRARIES += plugins/backend/mk-livestatus.la
 plugins_backend_mk_livestatus_la_SOURCES = plugins/backend/mk-livestatus.c