Code

core: Introduced the concept of time-series.
[sysdb.git] / src / Makefile.am
index 705b7e4558971a82838e5833aa91f18e96594a2f..c7c53e3289189d9fbb7a67ba4cd7151b18ba1758 100644 (file)
@@ -21,7 +21,8 @@ pkgcoreinclude_HEADERS = \
                include/core/object.h \
                include/core/plugin.h \
                include/core/store.h \
-               include/core/time.h
+               include/core/time.h \
+               include/core/timeseries.h
 pkgfeincludedir = $(pkgincludedir)/frontend
 pkgfeinclude_HEADERS = \
                include/frontend/connection.h \
@@ -30,6 +31,7 @@ pkgfeinclude_HEADERS = \
                include/frontend/sock.h
 pkgutilsincludedir = $(pkgincludedir)/utils
 pkgutilsinclude_HEADERS = \
+               include/utils/avltree.h \
                include/utils/channel.h \
                include/utils/dbi.h \
                include/utils/error.h \
@@ -69,14 +71,17 @@ libsysdb_la_SOURCES = \
                core/plugin.c include/core/plugin.h \
                core/store.c include/core/store.h \
                core/store-private.h \
+               core/store_expr.c \
                core/store_lookup.c \
                core/data.c include/core/data.h \
+               include/core/timeseries.h \
                frontend/connection.c include/frontend/connection.h \
                frontend/connection-private.h \
                frontend/parser.c include/frontend/parser.h \
                frontend/sock.c include/frontend/sock.h \
                frontend/session.c \
                frontend/query.c \
+               utils/avltree.c include/utils/avltree.h \
                utils/channel.c include/utils/channel.h \
                utils/error.c include/utils/error.h \
                utils/llist.c include/utils/llist.h \
@@ -87,7 +92,7 @@ libsysdb_la_SOURCES = \
                utils/unixsock.c include/utils/unixsock.h
 libsysdb_la_CFLAGS = $(AM_CFLAGS)
 libsysdb_la_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL)
-libsysdb_la_LDFLAGS = $(AM_LDFLAGS) -version-info 0:0:0 -pthread
+libsysdb_la_LDFLAGS = $(AM_LDFLAGS) -version-info 0:0:0 -pthread -lm
 libsysdb_la_LIBADD = libsysdb_fe_parser.la \
                $(LIBLTDL) -lrt liboconfig/liboconfig.la
 libsysdb_la_DEPENDENCIES = libsysdb_fe_parser.la liboconfig/liboconfig.la
@@ -122,7 +127,7 @@ sysdbd_SOURCES = tools/sysdbd/main.c include/sysdb.h \
                $(libsysdb_la_SOURCES)
 sysdbd_CFLAGS = $(AM_CFLAGS) -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\""
 sysdbd_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL)
-sysdbd_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -pthread
+sysdbd_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -pthread -lm
 sysdbd_LDADD = libsysdb_fe_parser.la liboconfig/liboconfig.la \
                $(LIBLTDL) -lrt
 sysdbd_DEPENDENCIES = libsysdb_fe_parser.la liboconfig/liboconfig.la