Code

Added initial client library implementation.
[sysdb.git] / src / Makefile.am
index 48e77eb34071da3d5c1136a9c835c5dbf19205bc..c3eb8cda89f651b74919474a90891ff72f15d70d 100644 (file)
@@ -3,6 +3,7 @@ SUBDIRS = liboconfig
 AM_CFLAGS = @STRICT_CFLAGS@
 AM_CPPFLAGS  = -Iinclude
 AM_CPPFLAGS += -DSYSCONFDIR='"${sysconfdir}"'
+AM_CPPFLAGS += -DLOCALSTATEDIR='"${localstatedir}"'
 AM_CPPFLAGS += -DPKGLIBDIR='"${pkglibdir}"'
 
 BUILT_SOURCES = include/sysdb.h
@@ -10,13 +11,37 @@ BUILT_SOURCES = include/sysdb.h
 pkginclude_HEADERS = include/sysdb.h
 pkgcoreincludedir = $(pkgincludedir)/core
 pkgcoreinclude_HEADERS = \
+               include/core/data.h \
+               include/core/error.h \
                include/core/object.h \
-               include/core/plugin.h
+               include/core/plugin.h \
+               include/core/store.h \
+               include/core/time.h
+pkgfeincludedir = $(pkgincludedir)/frontend
+pkgfeinclude_HEADERS = \
+               include/frontend/connection.h \
+               include/frontend/sock.h
 pkgutilsincludedir = $(pkgincludedir)/utils
 pkgutilsinclude_HEADERS = \
-               include/utils/llist.h
-
-lib_LTLIBRARIES = libsysdb.la
+               include/utils/channel.h \
+               include/utils/dbi.h \
+               include/utils/llist.h \
+               include/utils/proto.h \
+               include/utils/strbuf.h \
+               include/utils/unixsock.h
+
+pkgclientincludedir = $(pkgincludedir)/client
+pkgclientinclude_HEADERS = \
+               include/client/sock.h
+
+lib_LTLIBRARIES = libsysdbclient.la libsysdb.la
+
+libsysdbclient_la_SOURCES = \
+               client/sock.c include/client/sock.h
+libsysdbclient_la_CFLAGS = $(AM_CFLAGS)
+libsysdbclient_la_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL)
+libsysdbclient_la_LDFLAGS = -version-info 0:0:0 -pthread
+libsysdbclient_la_LIBADD = $(LIBLTDL)
 
 libsysdb_la_SOURCES = \
                sysdb.c include/sysdb.h \
@@ -25,8 +50,14 @@ libsysdb_la_SOURCES = \
                core/store.c include/core/store.h \
                include/core/data.h \
                core/error.c include/core/error.h \
+               frontend/connection.c include/frontend/connection.h \
+               include/frontend/connection-private.h \
+               frontend/sock.c include/frontend/sock.h \
+               frontend/session.c \
+               frontend/query.c \
                utils/channel.c include/utils/channel.h \
                utils/llist.c include/utils/llist.h \
+               utils/proto.c include/utils/proto.h \
                utils/strbuf.c include/utils/strbuf.h \
                core/time.c include/core/time.h \
                utils/unixsock.c include/utils/unixsock.h